subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angel Tsankov <fn42...@fmi.uni-sofia.bg>
Subject Re: libsvn_ra_neon-1.so.0: undefined symbol: GENERAL_NAME_free
Date Thu, 22 Jul 2010 12:30:54 GMT
Angel Tsankov wrote:
> Stefan Sperling wrote:
>> On Wed, Jul 21, 2010 at 09:19:26AM +0300, Angel Tsankov wrote:
>>> Stanimir Stamenkov wrote:
>>>> 20.7.2010 г. 14:32 +0300, /Angel Tsankov/:
>>>>
>>>>> When I run kdesvn I get a dialog showing the following message:
>>>>>
>>>>> Could not find our part: Cannot load library
>>>>> /usr/lib/kde4/kdesvnpart.so: (/usr/lib/libsvn_ra_neon-1.so.0:
>>>>> undefined symbol: GENERAL_NAME_free)
>>>>>
>>>>> Files /usr/lib/kde4/kdesvnpart.so and
>>>>> /usr/lib/libsvn_ra_neon-1.so.0 both exist. The former is part of
>>>>> kdesvn and the latter is part of subversion. In case this is
>>>>> relevant, I have installed the following packages:
>>>>>
>>>>> * openssl 0.9.8j (configured with --prefix=/usr 
>>>>> --openssldir=/usr/share);
>>>>> * neon 0.28.4 (configured with --prefix=/usr --with-ssl);
>>>>> * subversion 1.6.12 (configured with --prefix=/usr).
>>>>>
>>>>> Do I need to upgrade openssl or neon? Or is the problem elsewhere?
>>>> This is user mailing list for the general Subversion
>>>> distribution/client. I guess your question is more appropriate for
>>>> the kdesvn mailing list.
>>>>
>>> Since the problem is with libsvn_ra_neon-1.so.0 (which is part of
>>> Subversion), I think my question is appropriate for this mailing
>>> list, as well.
>>
>> The problem is most probably not with Subversion.
>> We get reports similar to yours quite a lot, and they usually are local
>> installation problems.
>>
>> You most likely have a local problem with your installation of Subversion
>> and related software. Quite possibly your kdesvn libraries were linked
>> against a different set of libraries than they are combined with at 
>> runtime.
>>
>> You don't mention if you're compiling kdesvn yourself, too.
>> If not done carefully, installing and running a mixture of 
>> vendor-provided
>> distribution packages and self-compiled binaries can cause subtle 
>> problems,
>> such as apparently random crashes, or unresolved symbol errors like 
>> you are
>> seeing. These can of course be fixed and worked around, but I'd like to
>> encourage you to use pre-compiled packages from your distribution vendor
>> instead.
>  >
>> Why are you compiling your own binaries? If you use binary packages
>> you won't have any such problems.
> 
> I want to make my own Linux distribution and I've compiled from source 
> almost every package except for firefox, thunderbird, and openoffice.
> 
> I agree that this is a local installation problem.  However, I am not 
> equally sure that the problem is *not* with Subversion: if the problem 
> is with some other package, can you explain how this package can "force" 
> libsvn_ra_neon-1.so.0 to use an undefined symbol (GENERAL_NAME_free)?
> 
> Just for information, neon was installed before subversion, and 
> subversion was installed before kdesvn.
> 
> Please note that I'm only trying to diagnose the problem.  I'm not 
> saying that subversion is buggy -- in fact, the problem might be in the 
> way I configured (or built) subversion. I'm just seeking help here...
> 
> Btw, could neon from Subversion's package have anything to do with this 
> issue?

It seems that configuring Subversion with '--with-neon=/usr' solved the 
problem.


Angel Tsankov


Mime
View raw message