subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yudong Sun <yud...@nag.co.uk>
Subject Re: How to build GNOME Keyring for Subversion
Date Wed, 11 Aug 2010 17:27:19 GMT
Hi,

Building KDELibs 4 for Kwallet is as embarrassing as building GNOME 
Keyring if not more. Even worse, KDE's installation guides are like 
puzzle books. I have to think about tring a binary distribution of 
Subversion with GNOME Keyring support. My system is the Cray Linux 
Environment (CLE) which is based SuSE Linux. I wonder if the openSUSE 
build may work on the system. Another trouble is that I don't have root 
access unable to do RPM installation. Is there a non-RPM binary package 
that I can unpack in a non-root user directory?

Thanks,

Yudong

Stefan Sperling wrote, On 09/08/2010 13:55:
> On Mon, Aug 09, 2010 at 01:28:54PM +0100, Yudong Sun wrote:
>> Hi,
>>
>> I am trying to build Subversion 1.6.12 with GNOME Keyring support. I
>> have tried GNOME Keyring 2.30.3 downloaded from
>> http://linux.softpedia.com/get/Utilities/gnome-keyring-13111.shtml
>> The configure and make of this GNOME Keyring version have been done
>> with two pkg-config files created: gcr-0.pc and gp11-0.pc but no
>> gnome-keyring-1.pc generated.
>>
>> I have also tried to install GNOME Keyring 2.28.2 downloaded from http://www.linuxfromscratch.org/blfs/view/svn/gnome/gnome-keyring.html
>> This version has an endless list of dependencies:
>>
>> GNOME Keyring 2.28.2:  GConf-2.28.0, GTK+-2.18.7, intltool-0.40.6,
>> Libgcrypt-1.4.5, and libtasn1-2.5
>>
>> GConf-2.28.0:  ORBit2-2.14.17 and polkit-0.94
>>
>> polkit-0.94:  D-Bus GObject Bindings-0.5, intltool-0.40.6,
>> Linux-PAM-1.1.1, gobject-introspection-0.6.8, and DocBook XML
>> DTD-4.5
>>
>> ... ...
>>
>> That looks terrifying. I am almost giving up midway
>>
>> I'd like to know your experience on building subversion with GNOME
>> Keyring. Which GNOME Keyring version works well with svn 1.6.12 and
>> is there an easier way to do it? Your advice will be much
>> appreciated.
> 
> Gnome-keyring's dependencies are outside of the Subversion project's control.
> So I'm afraid we cannot do much about it.
> Maybe try Kwallet? It might have a smaller list of dependencies.
> 
> The easiest way by far is using a distribution that offers readily working
> build scripts or binary packages. Most current Linux distributions and *BSD
> systems offer precompiled Subversion binaries with gnome-keyring support
> enabled.
> 
> Another possibility for a long-term fix to this problem would be contributing
> patches to Subversion that allow Subversion to encrypt passwords using GPGme.
> I'd very much appreciate any effort in this direction.
> 
> Stefan
> 
> ________________________________________________________________________
> This e-mail has been scanned for all viruses by Star.
> ________________________________________________________________________
> 

________________________________________________________________________
The Numerical Algorithms Group Ltd is a company registered in England
and Wales with company number 1249803. The registered office is:
Wilkinson House, Jordan Hill Road, Oxford OX2 8DR, United Kingdom.

This e-mail has been scanned for all viruses by Star. The service is
powered by MessageLabs. 
________________________________________________________________________

Mime
View raw message