subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Polder, Matthew J" <matthew.j.pol...@lmco.com>
Subject write permission issues with repository hosting
Date Fri, 29 Oct 2010 15:41:27 GMT
Hi,

We're running Subversion 1.6.12 on a Solaris 10 machine and hosting repositories on it. Users
can create and use repositories via svnadmin and svn locally on the Solaris machine via file:///<file:///\\>,
or they can check in and out via TortoiseSVN 1.6.8 on their PC via the http:///<http://>
protocol, with LDAP verification.

For a while this worked flawlessly, but then the machines were reconfigured and we can't get
it to work. We can either create and use the repositories locally but not through Tortoise
(we get the permission denied on txn-current-lock error) or we can use Tortoise but then not
check in locally (failed due to attempt to write a readonly database).

We've read the help on Supporting Multiple Repository Access Methods at http://svnbook.red-bean.com/en/1.5/svn.serverconfig.multimethod.html
and have tried those steps, though we're not sure what user should initially own the repository
(webservd, daemon?).

If anyone could point to us to further online docs or pointers we'd appreciate it!

matthew

Mime
View raw message