subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kmra...@rockwellcollins.com
Subject Re: Secure Connection Truncated/Insufficient system resources
Date Fri, 29 Oct 2010 16:10:22 GMT
Johan Corveleyn <jcorvel@gmail.com> wrote on 10/29/2010 08:43:26 AM:
> > In the Apache SSL error log on the server the corresponding message 
is:
> >
> > [Fri Oct 29 13:10:15 2010] [error] [client <IP_Address>] Provider
> > encountered an error while streaming a REPORT response.  [500, #0]
> >
> > [Fri Oct 29 13:10:15 2010] [error] [client <IP_Address>] A failure 
occurred
> > while driving the update report editor  [500, #721450]
> >
> > [Fri Oct 29 13:10:15 2010] [error] [client <IP_Address>] Can't read 
file
> > 'E:\\repository\\<repo_name>\\db\\revs\\20\\20795': Insufficient 
system
> > resources exist to complete the requested service.
> >
> <snip>
> >
> > The ?Insufficient system resources? message suggests a problem with 
the
> > server but I don?t see anything hogging memory or CPU and available 
disk
> > space is fine. The repository is quite large if that makes a 
difference (278
> > Gb on the server).
> 
> Wow, 278 Gb for a repository is *huge* IMHO. Are there a lot of large
> binary files in there?

One would wish this to be true.  I have many >300GB...

> Maybe the "insufficient resource" is related to the number of open
> file handles? I don't know how this works on Windows (or how you can
> configure it), but on *nix you have things like "ulimit" to limit the
> maximum number of file descriptors a process can have open
> simultaneously.
> 
> Is there anything special about revision 20795, the one that is
> referenced in the "insufficient system resources" message? Is it a
> very large rev file in the repository (the file
> 'E:\\repository\\<repo_name>\\db\\revs\\20\\20795')?

Is the repository packed?  I also was fairly regularly seeing this error
after I packed a large number of repositories on a windows server.
(Not sure that was related since I did see it less frequently
before the packing.  SAN vendors were changed and I also bumped up
the mod_dav version a few minor revs near same time.)  The error is
not always on the same repository nor even on the same revision or
pack file.  In most cases when this error occurs I was unable to
login to a new session on the server.  It seems that Windows 2003
(and before) has some fixed size memory buffers that can cause
this problem.

You can take a look at:

http://support.microsoft.com/kb/935649

(There are other kb articles that apply as well.  Just google
for the mentioned registry keys.)

Reconfiguring the mentioned registry keys seems to have
helped this server.  It does require a reboot and the usual
disclaimer that making changes with regedit could completely
disable your machine applies...

Server 2008 supposedly dynamically allocates these paged memory
pools, so upgrading may also help.

Kevin R.


Mime
View raw message