subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: subversion, davfs - problem after ugrade
Date Mon, 07 Mar 2011 23:53:34 GMT
The first step would be to study the changelogs
(http://svn.apache.org/repos/asf/subversion/branches/1.6.x) and/or
the CHANGES files and to identify the change that causes the regression.

Your best chance of getting this fixed in 1.6.17 (assuming it's indeed
a bug) is to tell us "<this> changed regressed <this> functionality".

Daniel
(I don't recall offhand a relevant change; there is a relevant CHANGES
entry in 1.6.13)

Andrzej Zawadzki wrote on Mon, Mar 07, 2011 at 23:17:13 +0100:
> On 07.03.2011 22:15, Konstantin Kolinko wrote:
> > 2011/3/6 Andrzej Zawadzki <zawadaa@gmail.com>:
> >> Hi!
> >>
> >> After upgrade from apache-mod_dav_svn-1.6.12 to
> >> apache-mod_dav_svn-1.6.1{5,6}
> >> my repo isn't accessible without authorization  process - with
> >> login/password - works.
> >>
> >> My apache error log file shows only:
> >>
> >> [Thu Mar 03 17:18:19 2011] [error] [client 192.168.201.1] Invalid method
> >> in request USERINFO /static/trunk/ HTTP/1.1
> >>
> >> I've simple repo, which is mounting from a few servers via mount.davfs2
> >> My configuration allows access without authorization and this works with
> >> 1.6.12
> >>
> >> Software:
> >> davfs2-1.4.6
> >>
> >> configuration:
> >>
> >>  <Location /static/trunk>
> >>                Satisfy Any
> > Why not Satisfy All?
> Hmm worked and works, and is working now with ver. 1.6.12  -(I think
> than conf is from manual)
> >>                Order deny,allow
> >>                Deny from all
> >>                Allow from 192.168.201.1
> >>
> > And the rest of the section?  
> Rest? :-)
> </Location>
> 
> > Is Dav enabled here?
> I said - this is working now...
> >  Is it even a
> > subversion repository? (it does not look like one)
> Hmm. SVN repo mounted via dav_svn to trunk - looks like...
> > Where is davfs2 in the picture? What is your client?
> My /etc/fstab:
> 
> https://svn.domain.com/static/trunk     
> /mnt/shared/public/static        davfs  
> _netdev,ro,uid=tomcat,gid=servlet,file_mode=0775,noauto   0       0
> 
> that's my client.
> 
> And... this is looks like some regression - or, now dav_svn need
> different configuration (strange if this is a minor upgrade).
> 
> Like I said - configuration is equal - only apache-mod_dav_svn is newer...
> For me it is a upgrade blocker - I need that functionality...
> 
> -- 
> Andrzej Zawadzki

Mime
View raw message