subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: Properties lost on checkin
Date Sat, 21 May 2011 17:12:01 GMT
Does http://subversion.tigris.org/issues/show_bug.cgi?id=3884 describe
the problem you were seeing?

Christoph Bartoschek wrote on Thu, May 19, 2011 at 11:12:01 +0200:
> Hi,
> 
> do I have to open an issue for this?
> 
> Am 17.05.2011 13:24, schrieb Daniel Shahaf:
> >I committed
> >
> >http://svn.apache.org/viewvc?view=rev&revision=r1104092
> >
> >before I saw this mail from you.
> >
> >(please add dev@ to CC if needed)
> >
> >Christoph Bartoschek wrote on Tue, May 17, 2011 at 11:06:47 +0200:
> >>Hi,
> >>
> >>I have a small script that reproduces the problem:
> >>
> >>dir=$PWD
> >>
> >>svnadmin create a
> >>svnadmin create b
> >>
> >>svn co file://${dir}/a ca1
> >>svn co file://${dir}/b cb1
> >>
> >>   cd ${dir}/ca1
> >>   touch file
> >>svn add file
> >>svn ci -m "Added file"
> >>   ln -sf file link
> >>svn add link
> >>svn ci -m "Added link"
> >>
> >>   cd ${dir}/cb1
> >>svn merge -r 0:1 file://${dir}/a .
> >>svn ci -m "Merged revision 1"
> >>svn up
> >>svn merge -r 1:2 file://${dir}/a .
> >>svn ci -m "Merged revision 2"
> >>
> >>   cd ${dir}
> >>svn co file://${dir}/b cb2
> >>
> >>ls -l cb1
> >>ls -l cb2
> >>
> >>Am 17.05.2011 12:00, schrieb Daniel Shahaf:
> >>>CC += dev@
> >>>
> >>>I haven't tried with 1.6.x, but merging a symlink-add from a foreign
> >>>repository does result in bogus state with current trunk:
> >>>
> >>>[[[
> >>>% $svn merge -c r922451 https://svn.apache.org/repos/asf/subversion/site/publish/
> >>>--- Merging (from foreign repository) r922451 into '.':
> >>>A    faq.en.html
> >>>% $svn st
> >>>~M      faq.en.html
> >>>% $svn info faq.en.html
> >>>Path: faq.en.html
> >>>Name: faq.en.html
> >>>Working Copy Root Path: /tmp/svn/wc1
> >>>URL: file:///tmp/svn/r1/trunk/faq.en.html
> >>>Repository Root: file:///tmp/svn/r1
> >>>Repository UUID: 0d8f1070-806c-11e0-a89b-a382cea1935c
> >>>Node Kind: file
> >>>Schedule: add
> >>>
> >>>% file faq.en.html
> >>>faq.en.html: ASCII text, with no line terminators
> >>>%
> >>>]]]
> >>>
> >>>
> >>>I'll forward this to dev@ (CC'ing you).
> >>>
> >>>
> >>>Christoph Bartoschek wrote on Tue, May 17, 2011 at 09:24:30 +0200:
> >>>>Hi,
> >>>>
> >>>>I have a workarea where I merged in some changes from a completely
> >>>>different repository. One of the changes was the creation of a link.
> >>>>After checking in I see that the link is ok in my workarea but not in
> >>>>any other workarea.
> >>>>
> >>>>This due to the missing svn:special keyword that was not checked in.
How
> >>>>can this happen?
> >>>>
> >>>>The following shows inconsistent behaviour in my opinion. How can this
> >>>>be explained:
> >>>>
> >>>>esquad$ svn proplist -v tm.h
> >>>>Properties on 'tm.h':
> >>>>    svn:special
> >>>>      *
> >>>>
> >>>>esquad$ svn info tm.h
> >>>>Path: tm.h
> >>>>Name: tm.h
> >>>>URL: https://server/trunk/include/tm/tm.h
> >>>>Repository Root: https://server
> >>>>Repository UUID: 608964b8-1798-474c-b2d9-552667dc04a5
> >>>>Revision: 27
> >>>>Node Kind: file
> >>>>Schedule: normal
> >>>>Last Changed Author: christoph
> >>>>Last Changed Rev: 26
> >>>>Last Changed Date: 2011-05-16 18:11:17 -0400 (Mon, 16 May 2011)
> >>>>Text Last Updated: 2011-05-17 02:51:09 -0400 (Tue, 17 May 2011)
> >>>>Checksum: 1a7ff762ceabb28ca8865f9b0ba377ff
> >>>>
> >>>>esquad$ svn proplist -v https://server/trunk/include/tm/tm.h
> >>>>
> >>>>esquad$ svn diff -r HEAD tm.h
> >>>>
> >>>>
> >>>>This shows that locally the svn:special keyword is set but not on the
> >>>>server. But svn does not see any difference. Is this a known bug?  Or
> >>>>how can I get the missing keywords checked in?
> >>>>
> >>>>
> >>>>Christoph
> >>
> 

Mime
View raw message