subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "D, Dinoj" <Dino...@Honeywell.com>
Subject RE: SVN Update is not happening from the server, though the status shows "Completed"
Date Thu, 05 May 2011 03:01:22 GMT
I don't think , it was of my mistake. I didn't set anything special to the working , simply
adding, committing and updating the working copy. And also the interface I am using for the
SVN operation is Tortoise SVN with default settings.

If you are saying it was because of "--depth", what would be the fix without altering anything
on the Working copy, recreating of working is not a good solution if the data is in huge amount.

Thanks & Regards,
Dinoj D
Desk: +91 80 26588360 Extn: 48547
Cell: +91 9916668051

-----Original Message-----
From: Stephen Butler [mailto:sbutler@elego.de] 
Sent: Wednesday, May 04, 2011 4:54 PM
To: D, Dinoj
Cc: Bob Archer; users@subversion.apache.org; Cheruvathoor, Anoop(IE10)
Subject: Re: SVN Update is not happening from the server, though the status shows "Completed"


On May 4, 2011, at 12:57 , D, Dinoj wrote:

> It is working with new working copy. Could you please let me know what
> are the main reasons behind this issue and how to avoid this not to come
> in future.

As Bob Archer mentioned below, the 'svn update --depth' command is buggy.

  http://subversion.tigris.org/issues/show_bug.cgi?id=3569
   " svn update --depth <DEPTH> allows making a working copy incomplete"

The issue is still open.

Of course, we're just guessing that this issue is related to your problem. 
You didn't mention what you did in the working copy before the problem 
occurred.  Was the --depth option used at all?

Can you reproduce the problem in a fresh working copy?  If so, please
provide the list of commands that cause the problem.

Steve

> 
> Thanks & Regards,
> Dinoj D
> Desk: +91 80 26588360 Extn: 48547
> Cell: +91 9916668051
> -----Original Message-----
> From: Bob Archer [mailto:Bob.Archer@amsi.com] 
> Sent: Wednesday, April 27, 2011 7:48 PM
> To: D, Dinoj; users@subversion.apache.org
> Subject: RE: SVN Update is not happening from the server, though the
> status shows "Completed"
> 
>> One of my team members made few changes to existing files in SVN.
>> When I performed SVN update, status shown is "Completed :
>> <versionno>"
>> But actually the files are not updated when checked for the
>> changes.
>> I tried to perform SVN clean and update, even then it is the same.
>> 
>> When I deleted the files and then performed update I now saw the
>> changes made are reflecting properly.
>> 
>> But I cannot delete the files and do SVN update every time I want
>> to see the updated files as it is a time consuming activity.
>> 
>> This issue is seen for the first time in my machine. Please help us
> 
> What version of svn?
> 
> Is this still happening with the new checkout?
> 
> It is possible you had a sparse checkout so you weren't getting the new
> files. I think there was an older version that had a bug which would
> label a checked out folder as immediate rather than full depth giving
> you a sparse checkout.
> 
> BOb
> 

--
Stephen Butler | Senior Consultant
elego Software Solutions GmbH
Gustav-Meyer-Allee 25 | 13355 Berlin | Germany
tel: +49 30 2345 8696 | mobile: +49 163 25 45 015
fax: +49 30 2345 8695 | http://www.elegosoft.com
Geschäftsführer: Olaf Wagner | Sitz der Gesellschaft: Berlin
Amtsgericht Charlottenburg HRB 77719 | USt-IdNr: DE163214194



Mime
View raw message