subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Canfield <andy.canfi...@pimco.mobi>
Subject svnadmin failure on nearly identical system
Date Fri, 22 Jul 2011 03:09:42 GMT
I have Ubuntu Linux 10.4 installed on my notebook computer named Lenny. 
I have the same system installed on my desktop computer named Athol (I 
had a lot of trouble getting that hardware to work). I have installed 
the Ubuntu Subversion packages on each; namely
         subversion
         libapache2-svn
         libgirepository-1.0-1
In both cases the SVNParentPath is /data/svn and that directory is owned 
by www-data:
*    drwxr-xr-x 5 www-data www-data 4096 2011-07-22 09:16 /data/svn*

Here is the critical command:
*    sudo -u www-data svnadmin create /data/svn/boofar*
On Lenny the command works, silently. On Athol I get this message:
*   svnadmin: error while loading shared libraries: libsvn_repos-1.so.0:
          cannot open shared object file: No such file or directory*
Apparently svnadmin cannot find something, but I don't know what it 
can't find. In both cases /usr/lib/libsvn_repos-1.so.1 is a symoblic 
link to:
*    -rw-r--r-- 1 root root 153700 2011-06-05 22:48 
/usr/lib/libsvn_repos-1.so.1.0.0*

I Googled for that error message and somebody had a problem with the 
home directory locations. The implication was that for some reason a 
Subversion distribution hard-codes the name of the home directory parent 
path (e.g. "/home"). No problem with my home directories; the 
arrangement is identical. On both machines my home directory is 
/data/andy and /home/andy is a symbolic link to /data/andy.

So any idea why svnadmin runs OK on one machine and fails on the other?


Mime
View raw message