subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Phippard <markp...@gmail.com>
Subject Re: Problems compiling 1.7.0 on redhat el4 64bit
Date Tue, 09 Aug 2011 14:24:44 GMT
On Mon, Aug 8, 2011 at 6:19 PM, <michael_rytting@agilent.com> wrote:

> For a while I was downloading and running the development build of
> subversion 1.7.0.  At one revision of the code I started having an issue
> where svn would immediately segfault.  At that time I stopped using 1.7.0
> assuming the issue would be fixed before release.  Unfortunately I just
> downloaded the beta2 release of 1.7.0 and I’m having the same problem.
> Interestingly enough I can successfully build beta2 on one of our 32bit
> systems, but I can’t use that build on our 64 bit systems because it tries
> to link against the 32bit version of libmagic.****
>
> ** **
>
> It’s important to note that I don’t get any errors compiling the design.
> It’s just that after I install it I get a segfault when I try and run svn.
> Ironically, if I run svn with no options or invalid options it successfully
> runs, but as soon as I add a valid option like “svn help” it segfaults.
> I’ve spent multiple hours trying to compile with different options to my
> LD_LIBRARY_PATH/PATH variables and I’ve tried to mix up how I build apr,
> apr-util, serf, and neon, but it always results in the same problem.****
>
> ** **
>
> I am using a very vanilla build process.****
>
> ** **
>
> Wget****
>
> Tar****
>
> ./get-deps.sh****
>
> ./configure –prefix=$HOME/local****
>
> make && make install****
>
> ** **
>
> As I’ve noted I have successfully built a development version of 1.7.0 on
> our 64bit systems in the past.
>

We see the same problem when compiling our binaries on RHEL 4 64-bit.  We
had to switch to building on RHEL 5.  I do not have the failing binaries
available to test any more.  Maybe it would help if you provided details on
the segfault like a dump or something?  I thought the problem was in our
build process so I did not raise the issue and we do not actually support
RHEL 4 anymore so I did not press it.

-- 
Thanks

Mark Phippard
http://markphip.blogspot.com/

Mime
View raw message