subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Phippard <markp...@gmail.com>
Subject Re: updates on subdirectories : revision not being pulled
Date Tue, 09 Aug 2011 18:31:30 GMT
On Tue, Aug 9, 2011 at 1:57 PM, Igor DEFAYE <i.defaye@sitealpha.ca> wrote:


> We have a major problem on our Apache Subversion. When updating some
> revisions are not pulled down to the pc, regardless of which pc we use.
>
> This seems to happen only when updating from a sub-directory and not
> updating from root directory, but it might also happen from root dir, I’ve
> just haven’t seen it happen yet.****
>
> ****
>
> I don’t know if this is an already known issue, or if I need to submit a
> new one. So I hope someone can help me look rapidly over this.****
>
> ** **
>
> Our server is up to date : 1.6.17 build 2190.74 . We administer the server
> via Collabnet Subversion Edge. We mostly use tortoise svn clients, they were
> updated but the problem is server side.****
>
> ** **
>
> We have noticed the revisions that are not pulled down to the pcs also do
> not appear in the change log on the subdirectory, but does on higher
> directories. ****
>
> ** **
>
> May be an example will make it clearer  :****
>
> On root directory we see the change log for revision 20445, it concerns
> only one file : /SuiteFM_dot_Net/Bin/www/ope_RAPPORT/js/container.js****
>
> Both Collabnet or tortoise show the same, so far so good.
>

Please do not mail dev@.  This is not a discussion about the development of
Subversion.

Based on your screenshots, I would suggest you look at revision 20453.  If
someone replaced the folder in that commit with an earlier version from its
history than everything in your screenshots makes perfect sense.  Basically
@ revision 20453, the folder was replaced, creating a new line of history
that does not include those other revisions.


-- 
Thanks

Mark Phippard
http://markphip.blogspot.com/

Mime
View raw message