subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Butler <sbut...@elego.de>
Subject Re: How to solve svnadmin load "File already exists" error?
Date Fri, 19 Aug 2011 17:11:17 GMT

On Aug 19, 2011, at 18:45 , Les Mikesell wrote:

> On 8/19/2011 11:20 AM, Dennis Jones wrote:
> 
>> 
>>> I would suggest to compare what actually is in that revision in the
>>> old and new repository. Do they match, or anything differs?
>> 
>> There is no new repository.  I am trying to create a new, clean repository
>> from the old server (of which I only have remote access).
> 
> Your new, clean repository should have the contents up to the commit that failed.

Dennis,

You could compare the histories of the problematic file (and its parent
directories) in the two repositories.  I'll bet there's some moves and
replacements there, as Konstantin suggests.

Does rsvndump support moved/replaced items?  I'm sure it's not
trivial.

> 
> But, it might be easier to use svnsync to do this.

According to the original post, the old repository doesn't support svnsync.

Regards,
Steve

--
Stephen Butler | Senior Consultant
elego Software Solutions GmbH
Gustav-Meyer-Allee 25 | 13355 Berlin | Germany
tel: +49 30 2345 8696 | mobile: +49 163 25 45 015
fax: +49 30 2345 8695 | http://www.elegosoft.com
Geschäftsführer: Olaf Wagner | Sitz der Gesellschaft: Berlin
Amtsgericht Charlottenburg HRB 77719 | USt-IdNr: DE163214194



Mime
View raw message