subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Jones" <djo...@grassvalleysoftware.com>
Subject Re: How to solve svnadmin load "File already exists" error?
Date Fri, 19 Aug 2011 16:20:32 GMT

"Konstantin Kolinko" <knst.kolinko@gmail.com> wrote in message 
news:CABzHfVmZ1Acxa5Vp2SBKcTyEZR8T3iH1xi2ogtsebyAY3dFf9w@mail.gmail.com...


>> I used rsvndump

> What is that? You mean you performed the dump remotely using svnrdump
> utility from some beta of svn 1.7 ? Does it work without replay
> support on the server? (Isn't this utility essentially the same as
> svnsync?)

No, I used "rsvndump", a third-party utility that I happened upon when 
googling for a way to dump a repository from an old server version <1.4.   I 
did try svnrdump from the 1.7 beta, but it (obviously) did not work because 
it requires the server to support replay.


> I would suggest to compare what actually is in that revision in the
> old and new repository. Do they match, or anything differs?

There is no new repository.  I am trying to create a new, clean repository 
from the old server (of which I only have remote access).


>
> When you performed the dump, do you have read access to all paths in
> the original repository?

Yes.


> Last time when I saw a message similar to yours was about a year ago,
> when I tried to commit revision that had complicated moves and renames
> / replaces in it. The svn client (Tortoise) failed to commit it with a
> similar message,  but when I rerun the operation it committed
> successfully. I still do not know what the cause was -- maybe some
> ordering between operations. (I am using HTTPS access protocol + neon
> + it was some version of 1.6 or 1.5 several months after release),

I've tried multiple times to re-run the operation.  It always fails at the 
same place.

- Dennis 




Mime
View raw message