subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Jones" <djo...@grassvalleysoftware.com>
Subject Re: How to solve svnadmin load "File already exists" error?
Date Tue, 23 Aug 2011 15:38:35 GMT
> I tried to edit a 5 Gb file on a Linuxserver we have with vi, it took some 
> 30 minutes to open the file but it did work!
>
> The format is quite simple :  a revision starts with the string :
>
> Revision-number:
>
> Just delete all the lines  until the next
>
> Revision-number:
>
>
> And the revision is removed from the dump. I am not quite sure if you need 
> to renumber the revisions afterwards though, but I
> don't think so.
>
> There is a problem though if what you delete is referenced later on in the 
> dump, then the load will fail.


Unfortunately, this did not work.  I was able to split the file into 
smaller, editable pieces, cut out the bad revision, and paste it all back 
together.  However, when I attempted to start loading at the revision 
following the bad one, I got checksum mismatches.  So I tried again with a 
new repository and tried to load a new dump file with everything in it 
except the bad revision (so it started from 0 again), and this time it 
failer even earlier than before, but again with a checksum mismatch.  Ugh. 
Subversion is a great tool overall, but getting this particular process to 
work has been utterly frustrating and ridiculously slow, not to mention 
error-prone, with no real explanation for the failing behaviors.

- Dennis 




Mime
View raw message