subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brenden Walker <BKWal...@drbsystems.com>
Subject RE: svn: E170001: Unable to connect to a repository at URL svn://
Date Mon, 12 Dec 2011 20:37:45 GMT
> -----Original Message-----
> From: Daniel Shahaf [mailto:d.s@daniel.shahaf.name]
> Sent: Monday, December 12, 2011 3:16 PM
> To: Jeff Kowalczyk; users@subversion.apache.org
> Subject: Re: svn: E170001: Unable to connect to a repository at URL
> svn://
> 
> Stefan Sperling wrote on Mon, Dec 12, 2011 at 20:58:39 +0100:
> > On Mon, Dec 12, 2011 at 07:53:42PM +0000, Jeff Kowalczyk wrote:
> > > Stefan Sperling <stsp <at> elego.de> writes:
> > > > >
> > > > > What dependency of subversion would be involved with svn://
> URLs only,
> > > > > such that
> > > > > a problem with that dependency would not affect subversion's
> ability to
> > > > > interface with http(s):// urls?
> > > > >
> > > > > I have rebuilt subversion, cyrus-sasl and neon. Current
> versions are:
> > > > >
> > > > > dev-vcs/subversion-1.7.1
> > > > > dev-libs/cyrus-sasl-2.1.25
> > > > > net-libs/neon-0.29.6
> > > >
> > > > E170001 means SVN_ERR_RA_NOT_AUTHORIZED.
> > > > This sounds some problem with your cyrus-sasl package.
> > > > Reminds me of this: http://marc.info/?l=openbsd-
> ports&m=131805779110751&w=2
> > >
> > > Thanks for the suggestion. I just now rebuild cyrus-sasl and
> subversion in that
> > > order. No change in behavior.
> >
> > Well, I don't know if the temporary error (missing .la files) that
> slipped
> > into the OpenBSD package is also present in gentoo.
> >
> > Just recompiling things won't magically fix anything.
> > You'll need to figure out if the gentoo sasl packages is broken or
> not.
> > Do other applications that use sasl work fine?
> 
> Do you use sasl authentication?  If not, try building svn without sasl.

Just thought I'd chime in here as I'm on Gentoo and working fine.  Just did an emerge --sync
and double checked my update status.

subversion-1.6.17-r78
cyrus-sasl-2.1.23-r4
neon-0.29.6

Those are the latest stable packages on x86 and amd64.  

I'm compiled with the following use flags enabled: apache2 berkdb dso extras gnome-keyring
sasl webdav-neon



Mime
View raw message