subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ruchi sharma <ruchisharma112...@gmail.com>
Subject Errors in Subversion 1.7 Build from source against Oracle HTTP server
Date Fri, 02 Dec 2011 06:22:59 GMT
Hi,

I'm trying to build subversion 1.7.1 from source on Linux against Oracle
HTTP server (64-bit, version 11.1.1.2.0 based on Apache 2.2.13
infrastructure). This is a critical project requirement
and I've spent many days already trying to fix the problems. The current
problem that the build is running into is this:
"Configure" run was successful and it created the makefile. Configure was
run this way -

./configure --prefix=$SOFTWARE_HOME/softwares/subversion-1.7.1/svn_install
--includedir=$SOFTWARE_HOME/softwares/subversion-1.7.1/svn_install/include
--srcdir=$SOFTWARE_HOME/softwares/subversion-1.7.1
--bindir=$SOFTWARE_HOME/softwares/subversion-1.7.1/svn_install/bin
--libdir=$SOFTWARE_HOME/softwares/subversion-1.7.1/svn_install/lib
--libexecdir=$SOFTWARE_HOME/softwares/subversion-1.7.1/svn_install/libexec
--sbindir=$SOFTWARE_HOME/softwares/subversion-1.7.1/svn_install/sbin
--enable-maintainer-mode --with-apr=$ORACLE_HOME/ohs/bin/apr-1-config
--with-apr-util=$ORACLE_HOME/ohs/bin/apu-1-config
--with-apxs=$ORACLE_HOME/ohs/bin/apxs
--with-neon=$SOFTWARE_HOME/softwares/subversion-1.7.1/neon/neon-0.29.0/neon-config
--enable-debug --enable-runtime-module-search --enable-shared
CPPFLAGS=-I$ORACLE_HOME/ohs/include

As you can see, the apr and apu configs are coming from Oracle HTTP server.

After this, when I run make, I run into this error:

cd subversion/libsvn_subr && /bin/sh
/scratch/softwares/subversion-1.7.1/libtool --tag=CC --silent --mode=link
gcc  -Wno-system-headers -Wold-style-definition -Wpointer-arith
-Wwrite-strings -Wshadow -ansi -Wall -Wformat=2 -Wunused -Waggregate-return
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wno-multichar -Wredundant-decls -Wnested-externs -Wunreachable-code
-Winline -Wno-long-long -g -g -pthread  -DSVN_DEBUG -DAP_DEBUG
-L/scratch/Oracle/Middleware/Oracle_WT1/lib
-L/scratch/Oracle/Middleware/Oracle_WT1/lib  -rpath
/scratch/softwares/subversion-1.7.1/svn_install/lib -version-info 0
-Wl,--no-undefined -o libsvn_subr-1.la  adler32.lo atomic.lo auth.lo
cache-inprocess.lo cache-membuffer.lo cache-memcache.lo cache.lo
checksum.lo cmdline.lo compat.lo config.lo config_auth.lo config_file.lo
config_win.lo constructors.lo ctype.lo date.lo debug.lo deprecated.lo
dirent_uri.lo dso.lo eol.lo error.lo hash.lo io.lo iter.lo kitchensink.lo
lock.lo log.lo macos_keychain.lo magic.lo md5.lo mergeinfo.lo nls.lo opt.lo
path.lo pool.lo prompt.lo properties.lo quoprint.lo sha1.lo
simple_providers.lo skel.lo sorts.lo sqlite.lo ssl_client_cert_providers.lo
ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo
subst.lo svn_base64.lo svn_cache_config.lo svn_string.lo
svn_temp_serializer.lo target.lo time.lo token.lo user.lo
username_providers.lo utf.lo utf_validate.lo validate.lo version.lo
win32_crashrpt.lo win32_crypto.lo win32_xlate.lo xml.lo
-L/scratch/Oracle/Middleware/Oracle_WT1/lib -laprutil-1
-L/scratch/Oracle/Middleware/Oracle_WT1/lib -lapr-1 -lexpat -lz  -ldl
-lpthread -lmagic
*/usr/lib/libexpat.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1*

This is my system config:
 uname -a
Linux 2.6.18-238.0.0.0.1.el5xen #1 SMP Tue Jan 4 09:38:01 EST 2011 x86_64
x86_64 x86_64 GNU/Linux

There are many versions of "libexpat.so" lying around on the system, but
even after running configure with "--with-expat" option and giving the
required INCLUDES and LIBRARY paths, make is still picking up the library
from /usr/lib.
I changed this line in the generated "libtool", in hopes that after this,
make will pick up the correct libexpat.so, which is coming from Oracle HTTP
server. But this too dint work:

# Run-time system search path for libraries.
sys_lib_dlsearch_path_spec="/usr/lib64
/scratch/Oracle/Middleware/Oracle_WT1/ohs/lib
/scratch/Oracle/Middleware/Oracle_WT1/lib /lib /usr/lib /usr/lib64/cmpi
/usr/lib/mysql /usr/lib64/mysql /usr/lib64/openais /usr/lib/opencryptoki
/usr/lib/opencryptoki/stdll /usr/lib64/opencryptoki/stdll
/usr/lib64/opencryptoki /usr/lib/oprofile /usr/lib64/oprofile
/usr/lib/qt-3.3/lib /usr/lib64/qt-3.3/lib /usr/lib/qt4/lib
/usr/lib64/qt4/lib64 /usr/lib/cmpi /usr/lib64/cmpi /usr/lib/cmpi
/usr/lib64/cmpi /usr/lib/cmpi /usr/lib64/cmpi /usr/lib64/cmpi
/usr/lib64/cmpi /usr/lib/cmpi /usr/lib64/cmpi /usr/lib64/cmpi
/usr/lib/xulrunner-1.9.2 /usr/lib64/xulrunner-1.9.2 "

Added the first 3 values - "/usr/lib64
/scratch/Oracle/Middleware/Oracle_WT1/ohs/lib
/scratch/Oracle/Middleware/Oracle_WT1/lib"

Any thoughts on how this can be resolved? Please help out as this is very
critical and lot of time has already been spent to make this work.

Thanks,
RS.

Mime
View raw message