subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Becroft <djcbecr...@gmail.com>
Subject SVN 1.7 repository + Jenkins
Date Wed, 07 Dec 2011 02:33:12 GMT
Hi,

We're testing upgrading our SVN repositories to 1.7 format, and have
noticed something a bit strange.

In Jenkins (1.441), I can set the SVN URL to checkout from, and it
validates whether it is correct. With a 1.7 repository, however, it doesn't
seem to validate correctly (error is "/trunk/foo doesn't exist in the
repository"). I'm not sure exactly what command it is using to
connect/validate, but from the svnserve logs, I can see the following:

Subversion 1.6:

1236984 2011-12-07T02:15:56.090125Z 192.168.30.145 - repos open 2
cap=(edit-pipeline svndiff1 absent-entries depth mergeinfo log-revprops)
/trunk/foo - -
1236984 2011-12-07T02:15:56.090125Z 192.168.30.145 - repos get-latest-rev
1236984 2011-12-07T02:15:56.090125Z 192.168.30.145 - repos check-path
/trunk/foo@3
1236984 2011-12-07T02:15:56.105750Z 192.168.30.145 - repos open 2
cap=(edit-pipeline svndiff1 absent-entries depth mergeinfo log-revprops)
/trunk/foo - -
1236984 2011-12-07T02:15:56.105750Z 192.168.30.145 - repos get-latest-rev
1236984 2011-12-07T02:15:56.105750Z 192.168.30.145 - repos check-path
/trunk/foo@3

Subversion 1.7:

7232 2011-12-07T02:27:43.779133Z 127.0.0.1 - svnrepos open 2
cap=(edit-pipeline svndiff1 absent-entries depth mergeinfo log-revprops)
/trunk/foo - -
7232 2011-12-07T02:27:43.779133Z 127.0.0.1 - svnrepos get-latest-rev
7232 2011-12-07T02:27:43.779133Z 127.0.0.1 - svnrepos check-path
/trunk/foo/trunk/foo@2
7232 2011-12-07T02:27:43.794758Z 127.0.0.1 - svnrepos open 2
cap=(edit-pipeline svndiff1 absent-entries depth mergeinfo log-revprops)
/trunk/foo - -
7232 2011-12-07T02:27:43.794758Z 127.0.0.1 - svnrepos get-latest-rev
7232 2011-12-07T02:27:43.794758Z 127.0.0.1 - svnrepos check-path
/trunk/foo/trunk@2
7232 2011-12-07T02:27:43.794758Z 127.0.0.1 - svnrepos check-path
/trunk/foo/trunk/foo@2

The 1.7 repositories were created with svnadmin create/svnsync, rather than
a dump/load cycle.

Using the same version of Jenkins (and SVN client), it seems that the
check-path lines are incorrect for 1.7 (it's doubling up). I can
successfully checkout the repositories from both servers.

We've also noticed some similar messages appearing with Subclipse, but
these appear to be sporadic.

Any ideas?

---
Daniel Becroft

Mime
View raw message