subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben" <b...@qqmail.nl>
Subject RE: Crash after upgrading to 1.7.2 from 1.6.1 in KDevelop
Date Tue, 24 Jan 2012 12:01:25 GMT


> -----Original Message-----
> From: Aaron Williams [mailto:Aaron.Williams@cavium.com]
> Sent: dinsdag 24 januari 2012 8:29
> To: users@subversion.apache.org
> Subject: Crash after upgrading to 1.7.2 from 1.6.1 in KDevelop
> 
> Hi all,
> 
> I upgraded Subversion in OpenSUSE 12.1 from the default 1.6.1 to 1.7.2
> compiled from sources.
> 
> After upgrading I am seeing kdevelop crash each time I right click in the
> editor.  It gives me the following stack trace:
> 
> Thread 2 (Thread 0x7f36f4b84700 (LWP 8151)):
> [KCrash Handler]
> #6  svn_wc__db_wcroot_parse_local_abspath (wcroot=0x7f36f4b835b0,
> local_relpath=0x7f36f4b835b8, db=0x0, local_abspath=0x7f3700d4b758
> "/home/aaronw/projects/tot/sdk/bootloader/u-
> boot/drivers/mmc/octeon_mmc.c",
> result_pool=0x7f3700d41028, scratch_pool=0x7f3700d41028) at
> subversion/libsvn_wc/wc_db_wcroot.c:383

This looks like a bug in kdevelop to me. The DB parameter must be a valid
reference.

My best guess would be that kdevelop just initializes a
svn_wc_client_context_t with all 0s, while it should have used
svn_client_create_context (). In Subversion <= 1.6 this worked ok for some
operations although it was documented as *don't do this* since well before
1.0. Since Subversion 1.7 it will create this crash.

Googling for kdevelop and Subversion got me:
https://bugs.kde.org/show_bug.cgi?id=284061

Which validates my guess, and says it has been fixed since October 2011. So
you should probably upgrade your kdevelop.

	Bert



Mime
View raw message