subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Hourihane <al...@fairlite.co.uk>
Subject Re: Subversion 1.7.4 should use pkg-config for sqlite3 libraries
Date Wed, 25 Apr 2012 22:46:54 GMT
On 04/25/12 23:34, Philip Martin wrote:
> Alan <alanh@fairlite.co.uk> writes:
>
>> It seems that subversion just tries linking explicitly with -lsqlite3
>> during configure, yet sqlite3 itself may be linked against other
>> libraries which need to be pulled in. And this can fail on some systems.
>>
>> The configure script should use "pkg-config --libs sqlite3" to obtain a
>> list of libraries.
> Subversion does use pkg-config after first trying /usr.  Are you saying
> this does not work?  If I temporarily remove the library from /usr I see
>
> configure: checking sqlite library
> checking sqlite amalgamation... no
> checking sqlite3.h usability... yes
> checking sqlite3.h presence... yes
> checking for sqlite3.h... yes
> checking sqlite library version (via header)... okay
> checking for sqlite3_close in -lsqlite3... no
> checking sqlite library version (via pkg-config)... 3.7.10
>
>
Just to note that I'm passing --with-sqlite=/usr on the configure line too.

Alan.

Mime
View raw message