subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tsunam <tsu...@gmail.com>
Subject SVN ro proxy failures with Copy or Move functionality
Date Mon, 02 Apr 2012 20:19:13 GMT
Hi all,

At a bit of a loss and can't entirely figure out the cause of the issue.
>From the mirror users can create new files to be added, but the delete/copy
aspects fail when run through the proxy. If the users relocate to the
master and run the same command it works without issue.

So there's something amiss in the proxy configuration that is causing an
issue with how its passing activities over to the master.

Master is a Windows 2008 server running collabnet's subversion edge
1.6.17.2125.68.
Slave/proxy is a RHEL5 server running 1.6.11-7 on top of apache.

relevant section of the mirror:

<Location /svn/cm-sun>
 DAV svn
        SVNPath /var/satellite/repos/cm-sun
        SVNMasterURI http:/masterurl/svn/cm
        AuthName "Code Mirror Repository"
        AuthType Basic
        AuthzLDAPAuthoritative on
        AuthBasicProvider ldap
        AuthLDAPBindDN Domain\User
        AuthLDAPBindPassword password
        AuthLDAPUrl "ldap://dc1:3268
dc02:3268/DC=domain,DC=com?sAMAccountName?sub?(objectClass=user)" "NONE"
        require valid-user
        SVNPathAuthz on
        AuthUserFile "/git/admin-sun/Apache/conf/cm_authz.lst"
        AuthzSVNAccessFile "/git/admin-sun/Apache/conf/cm_authz.lst"
</Location>

Any help/suggestions would be appreciated.

Mime
View raw message