subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Podskubka <s.podsku...@hcs.at>
Subject Re: Error with file externals
Date Tue, 08 May 2012 13:50:27 GMT
Hello list,

> I tried coming up with a simple repro-script but there it worked, of 
> course...
>
I didn't manage to reproduce the error with the file:// protocol, but 
with http:// I was able to reproduce it.
Still on Windows 7, still using subversion 1.7.4 on the client and 
subversion 1.4.3 on the server with Apache 2.0.52 serving the repository.
http://192.168.0.22/svn/repos/test123 is an empty repository.

The script:
----------
svn co http://192.168.0.22/svn/repos/test123 wc123
echo test >wc123\test1.txt
svn add wc123\test1.txt
svn ci -m "initial checkin" wc123
svn up wc123
svn propset svn:externals "^/test1.txt test2.txt" wc123
svn up wc123
svn up wc123
----------

The last update outputs the following:
----------
Updating 'wc123':

Fetching external item into 'wc123\test2.txt':
svn: warning: W160016: Failure opening '/test1.txt/test2.txt'

At revision 1.
svn: E205011: Failure occurred processing one or more externals definitions
----------

I tried the same with the subversion repository (apparently subversion 
1.7.0), there I could not reproduce the error with the following script. 
Everything went well.
----------
C:\SVN>svn co http://svn.apache.org/repos/asf/subversion/trunk/doc wcsvn
C:\SVN>svn propset svn:externals "../INSTALL INSTALL" wcsvn
C:\SVN>svn up wcsvn
C:\SVN>svn up wcsvn
----------

So maybe it is related to the server version and the communication protocol.

Anyway, if the bug cannot be found I could always use directory 
externals instead of file externals, they work just fine.

Best regards,
Stefan

Mime
View raw message