subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brenden Walker <BKWal...@drbsystems.com>
Subject propset --revprop -r HEAD svn:externals not working (visual SVN server)
Date Tue, 01 May 2012 17:12:08 GMT
I've been trying to set properties in my repo with a command similar to:

svn.exe propset --revprop -r HEAD svn:externals "https://devsubversion/svn/Development/Trunk/Projects/XCCS/Exports@1394
Externals/XCCS" https://devsubversion/svn/Development_TEST/Tags/SiteWatch/RC_1/Projects/SiteWatch/

svn reports it worked  "property 'svn:externals' set on repository revision 1496" however
nothing is changed.  I tried slik svn client, the one that comes with tortoise as well as
one compiled on a linux box.  Same results.  I've tried -file, variations on the format of
the external without the pin revision..etc.. No luck.

Perhaps a bug in  VisualSVN server (what we're using currently).  However I thought I'd ask
the list first to see if this is a known problem.  Or maybe the format is just wrong.

And yes, I have a pre-prop hook.

I ended up working around this by checking out locally, setting props and commit.. that works
fine.

Mime
View raw message