subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julius Smith <...@ccrma.stanford.edu>
Subject Upgrade to v1.7 = death of working copies
Date Fri, 11 May 2012 01:43:56 GMT
On my MacBook, MacPorts upgraded me to subversion 1.7 at some point, and
when notified to upgrade my working copies, I did so.  My svn server is a
Linux machine running Fedora 16 (the most recent Fedora release of last
November).  Unfortunately it does not offer subversion 1.7 and will only go
up to 1.6.  (Version 1.7 is available in an alpha future version of Fedore,
but I cannot risk going to that on my server.) nCoincidentally, I was cut
off from my server for a week due to a spurious IP address change by
comcast, so now I cannot check in a week's worth of changes in several
working copies.  I tried downgrading to 1.6 in Mac Ports, but no matter
what I do it insists on installing 1.7, ignoring my specification of a 1.6
release that I know exists.  So, three bug reports:

1. MacPorts refusing to downgrade back to 1.6.

2. Fedora not offering the latest stable version of subversion.

3. Subversion allowing working copies to be "upgraded" without verifying
that they can be checked in afterwards.  In other words, the server should
be required to upgrade first.

Also, what happened to compatibility across at least one major release
number?  I thought nearly all software packages did that.

In the meantime, I guess I have to export all my working copies and
manually merge them back to the server and delete all my working copies.
I also might as well uninstall subversion on my MacBook until Fedora 17
comes out and I get around to upgrading to it.  However, I doubt I will
take the chance of going through this again.

 - Julius Smith

-- 
"Anybody who knows all about nothing knows everything" -- Leonard Susskind

Mime
View raw message