subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Pounsett <m...@conundrum.com>
Subject Cleaning out an old subscriber
Date Wed, 11 Jul 2012 15:30:55 GMT
Hi List Admins.  Sorry, but I couldn't find a list admin address on the web site for this,
so I'm sending it to the list itself.

I'm sure others have seen this too, but any time I post to the list I'm getting a bounce from
world.deshaw.com.  Could an admin track down this subscriber and remove them from the list?

Thanks,
   Matt Pounsett


Begin forwarded message:

> From: Postmaster <systems-postmaster@world.deshaw.com>
> Subject: Important: message being returned.
> Date: July 11, 2012 11:02:20 EDT
> To: matt@conundrum.com
> Reply-To: nobody@world.deshaw.com
> 
> Thank you for your inquiry.  Justin Vallon is no longer with the firm.  For immediate
assistance, please contact Reception at +1-212-478-0000.
> 
> Sincerely,
> The D. E. Shaw Group
> 
> 
> -- 8< --- CUT HERE -------------------------- CUT HERE --- >8 --
> 
>  From:    Matthew Pounsett <matt@conundrum.com>
>  To:      Jason Heeris <jason.heeris@gmail.com>
>  cc:      users@subversion.apache.org
>  Subject: Re: Square brackets in file names and authz (in VisualSVN 2.5.5)
> 
> 
>  On 2012/07/11, at 01:13, Jason Heeris wrote:
> 
>> The problem is this: it doesn't seem to work on files with the '[' or ']' characters
in their name. Ignoring VisualSVN's GUI for now, I've tried going one step further and editing
the "authz-windows" file by hand and I just can't seem to get it to work. I've tried variations
like:
> 
>  I note by your examples that you're using a unix filesystem (as opposed to Windows).
 I would be a little surprised if this worked there, since the square brackets are normally
used by unix shells as glob metacharacters, similarly to * and ?. 
> 
>  For example, 'tmp[123].txt' is a glob pattern to match tmp1.txt, tmp2.txt and tmp3.txt.
> 
>  Sorry, I'm not sure how to help you make this work.  If you can avoid using those characters
in file names, please do so at all costs.  A good rule of thumb is that if you can't create
the file from a command line in a shell without escaping characters, then don't use those
characters.  
> 
> 
>> It's also worth pointing out that some paths have the "#" character in them. What
do I do when I get to those?
> 
>  This is commonly comment character.  It's possible to create a file with this character
in it, but personally I'd avoid it.  It's possible you could escape it like so: "tmp\#1.txt",
but I'm not confident that will work.  If svn can't deal with this one you might have a case
for it being a bug, since it is technically a legal file name.
> 
> 
> 
> 


Mime
View raw message