subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kapur, Rajneesh" <RKa...@activehealth.net>
Subject RE: unable to login to svn repo
Date Thu, 26 Jul 2012 20:21:00 GMT
Hi Philip,

Do you mean I should have authz file as follows:

[groups]
harry_and_sally = harry,sally
[repo4:/home/RKapur]
@harry_and_sally = rw
* = r

But still I get the same error:
-------------------------start Logs ---------------------------
22673 2012-07-25T16:16:08.256530Z 172.20.33.153 - home/RKapur/repo4 get-latest-rev
22675 2012-07-25T16:16:08.299955Z 172.20.33.153 - home/RKapur/repo4 open 2 cap=(edit-pipeline
svndiff1 absent-entries depth mergeinfo log-revprops) / SVN/1.7.5 -
22674 2012-07-25T16:16:08.300281Z 172.20.33.153 - home/RKapur/repo4 open 2 cap=(edit-pipeline
svndiff1 absent-entries depth mergeinfo log-revprops) / SVN/1.7.5 TortoiseSVN-1.7.7.22907
22675 2012-07-25T16:16:08.310292Z 172.20.33.153 - home/RKapur/repo4 get-latest-rev
22674 2012-07-25T16:16:08.310620Z 172.20.33.153 - home/RKapur/repo4 get-latest-rev
22675 2012-07-25T16:16:08.320291Z 172.20.33.153 - home/RKapur/repo4 reparent /
22674 2012-07-25T16:16:08.320943Z 172.20.33.153 - home/RKapur/repo4 reparent /
22675 2012-07-25T16:16:08.354066Z 172.20.33.153 harry home/RKapur/repo4 ERR subversion/svnserve/serve.c
167 170001 Authorization failed
22674 2012-07-25T16:16:08.355295Z 172.20.33.153 harry home/RKapur/repo4 ERR subversion/svnserve/serve.c
167 170001 Authorization failed
22676 2012-07-25T16:16:08.421417Z 172.20.33.153 - home/RKapur/repo4 open 2 cap=(edit-pipeline
svndiff1 absent-entries depth mergeinfo log-revprops) / SVN/1.7.5 TortoiseSVN-1.7.7.22907
22676 2012-07-25T16:16:08.439116Z 172.20.33.153 - home/RKapur/repo4 get-latest-rev
22676 2012-07-25T16:16:08.456547Z 172.20.33.153 - home/RKapur/repo4 reparent /
22676 2012-07-25T16:16:08.513273Z 172.20.33.153 harry home/RKapur/repo4 ERR subversion/svnserve/serve.c
167 170001 Authorization failed
22677 2012-07-25T16:16:08.552601Z 172.20.33.153 - - ERR subversion/svnserve/serve.c 2847 210005
No repository found in 'svn://192.168.4.64/home/RKapur'
22678 2012-07-25T16:16:08.584572Z 172.20.33.153 - - ERR subversion/svnserve/serve.c 2847 210005
No repository found in 'svn://192.168.4.64/home'
22679 2012-07-25T16:16:08.615740Z 172.20.33.153 - - ERR subversion/svnserve/serve.c 2847 210005
No repository found in 'svn://192.168.4.64'
-------------------------end Logs ---------------------------

I can't seem to understand what's wrong and how to fix it. Thanks for help.


> Thanks Philip, Thorsten, and Ryan
>
> Do you mean the repository is a directory 'repo4' on disk?
> ----> Yes, my repository is named: repo4 - located at /home/RKapur with absolute path
/home/RKapur/repo4

> You are right - looks like tortoiseSVN or "svn" client can't find the repository. I just
tried with tortoiseSVN and I see more logs in server log file:
>
> -------------------------start Logs -----------------------------------------------------------------------------
> 19269 2012-07-25T14:58:19.946784Z 172.20.33.153 - home/RKapur/repo4 open 2 cap=(edit-pipeline
svndiff1 absent-entries depth mergeinfo log-revprops) / SVN/1.7.5 -
> 19269 2012-07-25T14:58:19.959811Z 172.20.33.153 - home/RKapur/repo4 get-latest-rev
> 19268 2012-07-25T14:58:19.959823Z 172.20.33.153 - home/RKapur/repo4 get-latest-rev
> 19269 2012-07-25T14:58:19.970012Z 172.20.33.153 - home/RKapur/repo4 reparent /
> 19268 2012-07-25T14:58:19.970035Z 172.20.33.153 - home/RKapur/repo4 reparent /
> 19268 2012-07-25T14:58:20.003675Z 172.20.33.153 harry home/RKapur/repo4 ERR subversion/svnserve/serve.c
167 170001 Authorization failed

The repository has been found.  As I said in my previous mail your authz
file:

> 2) authz file
> [aliases]
> [groups]
> harry_and_sally = harry,sally
> [repository:/home/RKapur/repo4]
> @harry_and_sally = rw

only provides access to a repository called 'repository', it provides no
access to a repository called 'repo4'.

> It looks like when I used "svnadmin create /home/RKapur/repo4" then the directory permissions
were not set correctly. It might be because of the user "rkapur" that I am logged in as. Is
this correct? Do I have to login as "root"? If so then I have to ask our system admins. as
I don't have "root" access. I also checked in other machine where we have older linux ES release
4 (Nahant Update 9) -

You need to fix your authz file.  Your layout is very confusing.  You
have a repository on disk at the path /home/RKapur/repo4 and you are
providing authz rules for the path /home/RKapur/repo4 inside the
repository.  It's not impossible for the path inside the repository to
be the same as the path to the repository but it is unconventional.

--
Philip

IMPORTANT WARNING: Information contained in this email is intended for the use of the individual
to whom it is addressed, and may contain information that is privileged, confidential, and
exempt from disclosure under applicable law. If you are not the intended recipient, or the
employee or agent responsible for delivering the message to the intended recipient, you are
hereby notified that any dissemination, distribution, or copying of this communication is
STRICTLY FORBIDDEN. If you have received this communication in error, please notify us immediately
by return email and delete this document. Thank you.

Mime
View raw message