subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Heeris <jason.hee...@gmail.com>
Subject Re: svndumpfilter does not exclude some files
Date Mon, 15 Oct 2012 04:56:40 GMT
Okay, I managed to cheat a bit, so I'm sharing my workaround here. In
my includes file, I used the form:

  /specs*01234*

...and for the directories:

  /results/RST-0001 (v0.01) #001*

...and now everything seems to be expunged that should be.

I have no idea why the original form doesn't work, maybe it's the "["
characters or somesuch. Obviously you need to be a bit careful that
your patterns aren't too general; in my case those five-digit numbers
are a unique enough pattern to work for me.

— Jason

On 15 October 2012 09:57, Jason Heeris <jason.heeris@gmail.com> wrote:
> I am trying to use svndumpfilter to remove specific files and
> directories from a repository dump, but I can't seem to remove all of
> them.
>
> Some of the files are, for example:
>
>   /specs/[01234] product x spec.pdf
>
> There are other files in other top-level directories, but they all
> have that "[xxxxx]" prefix.
>
> There are also some directories I'm filtering out such as:
>
>   /results/RST-0001 (v0.01) #001
>
> I created a text file to list these excluded path prefixes. I enter
> each directory into it verbatim, but for the files I just enter the
> prefix up to and including the "[01234]" part (to catch any moves,
> renames, etc). So my "excludes.txt" contains something like
>
>   /specs/[01234]
>   ...bunch of similar path prefixes
>   /results/RST-0001 (v0.01) #001
>   ...bunch of similar path prefixes
>
> I use 'svnadmin dump' to dump the repository contents, and then run
>
>   svndumpfilter exclude --targets "excludes.txt" < repo-01.dump >
> repo-02.dump 2> filter.log
>
> Unfortunately, only the directories (the second kind of entries in my
> 'excludes.txt') seem to get filtered. Looking in 'filter.log', there's
> no mention of removing the files starting with "[xxxxx]", but it does
> explicitly say that the other directories were removed (although it
> doesn't list all the files under them). Loading the resulting dump
> file into a repository, the files are certainly still there, but the
> directories aren't.
>
> I've also tried putting a "*" on the end of each line and using the
> "--pattern" argument, but the files are still not filtered out.
>
> So how do I get svndumpfilter to get rid of these files from my
> repository? Each dump/load cycle takes about seven hours, so I'm not
> really able to try a lot of trial and error.
>
> All of this is done on Windows Server 2003. Versions of both svnadmin
> and svndump are 1.7.5 (r1336830), and they're the binaries that come
> with VisualSVN server 2.5.5.
>
> Please CC me on replies.
>
> — Jason Heeris

Mime
View raw message