subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben" <b...@qqmail.nl>
Subject RE: Problem building on OS X Lion
Date Sun, 24 Mar 2013 02:38:46 GMT


> -----Original Message-----
> From: Patrick May [mailto:patrick.may@mac.com]
> Sent: zaterdag 23 maart 2013 14:29
> To: users@subversion.apache.org
> Subject: Problem building on OS X Lion
> 
> 	I downloaded the subversion-1.7.8 tar ball and attempted to build it
> on OS X 10.8.3 with the latest version of Xcode installed.  After
"configure --
> prefix=/usr/local", running make gives the errors attached below.  Is
there
> something wrong with my build environment?
> 
> Thanks,
> 
> Patrick
> 
> cd subversion/svn && /bin/sh /Users/Patrick/packages/subversion-
> 1.7.8/libtool --tag=CC --silent --mode=link gcc  -g -O2
-Werror=implicit-
> function-declaration   -rpath /usr/local/lib  -o svn  add-cmd.lo
blame-cmd.lo
> cat-cmd.lo changelist-cmd.lo checkout-cmd.lo cleanup-cmd.lo commit-
> cmd.lo conflict-callbacks.lo copy-cmd.lo delete-cmd.lo diff-cmd.lo export-
> cmd.lo help-cmd.lo import-cmd.lo info-cmd.lo list-cmd.lo lock-cmd.lo log-
> cmd.lo main.lo merge-cmd.lo mergeinfo-cmd.lo mkdir-cmd.lo move-cmd.lo
> notify.lo patch-cmd.lo propdel-cmd.lo propedit-cmd.lo propget-cmd.lo
> proplist-cmd.lo props.lo propset-cmd.lo relocate-cmd.lo resolve-cmd.lo
> resolved-cmd.lo revert-cmd.lo status-cmd.lo status.lo switch-cmd.lo tree-
> conflicts.lo unlock-cmd.lo update-cmd.lo upgrade-cmd.lo util.lo
> ../../subversion/libsvn_client/libsvn_client-1.la
> ../../subversion/libsvn_wc/libsvn_wc-1.la
> ../../subversion/libsvn_ra/libsvn_ra-1.la
> ../../subversion/libsvn_delta/libsvn_delta-1.la
> ../../subversion/libsvn_diff/libsvn_diff-1.la
> ../../subversion/libsvn_subr/libsvn_subr-1.la -laprutil-1 -lapr-1
-L/usr/local/lib
> -lneon -lz -L/opt/local/lib -lssl -lcrypto -dynamic
-Wl,-search_paths_first -
> lkrb5 -lexpat -framework Security -framework CoreFoundation -framework
> CoreServices
> ld: warning: ignoring file /usr/local/lib/libaprutil-1.dylib, missing
required
> architecture x86_64 in file /usr/local/lib/libaprutil-1.dylib (2 slices)
> ld: warning: ignoring file /usr/local/lib/libapr-1.dylib, missing required
> architecture x86_64 in file /usr/local/lib/libapr-1.dylib (2 slices)
> ld: warning: ignoring file /usr/local/lib/libz.a, file was built for
archive which is
> not the architecture being linked (x86_64): /usr/local/lib/libz.a
> ld: warning: ignoring file /usr/local/lib/libexpat.dylib, missing required
> architecture x86_64 in file /usr/local/lib/libexpat.dylib (2 slices)
> Undefined symbols for architecture x86_64:

It looks like you're trying to buil dan x64 version of subversion, but you
only have a x86 version of the required dependency apr.

You should either install a x64 apr first, or build subversion as x86.
(I would recommend doing whatever is easier for you, as the result will be
virtually the same. Subversion doesn't need that much memory)

	Bert


Mime
View raw message