subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alagazam.net Subversion" <...@alagazam.net>
Subject Re: windows binaries with xampp
Date Fri, 22 Mar 2013 21:53:48 GMT
On 2013-03-21 21:01, Andrew Peterson wrote:
> Has anyone successfully used xampp with the binaries from:
> Win32Svn <http://sourceforge.net/projects/win32svn/> (32-bit client, 
> server and bindings, MSI and ZIPs; maintained by David Darj 
> <http://alagazam.net/>)
>
> I've tried a bunch of different configurations, but every time I tried 
> to load the mod_dav_svn.so and the mod_authz_svn.so, apache just 
> crashes and tells me it can't load the module.
>
> Thanks,
>
> Andrew
>
>
Hi

I just tested xampp 1.7.4 with Subversion  1.7.8 (Apache 2.2 version) 
and it worked.
Also got xampp 1.8.1 working with Subversion 1.7.8 (Apache 2.4 version).
I was unsure that the 1.8.1 should work since it said it was compiled 
with vc9 (Visual studio 2008) and I use vc6 (Visual Studio 6) for the 
subversion build. But it worked.

All i did was unpacking the Subversion zip file to C:\Subversion.
Creating a repository with "C:\Subversion\bin\svnadmin create C:\Svn.repo"
Adding the following to C:\xampp\Apache\conf\httd.conf

LoadModule dav_module         modules/mod_dav.so
LoadModule dav_svn_module     C:/Subversion/bin/mod_dav_svn.so

<Location /svn>
   DAV svn
   SVNPath C:/Svn.repo
</Location>

Then restarting Apache.
Didn't even have to add subversion bin folder to the system path variable.
Directing the webbrowser to http://localhost/svn then showed the 
subversion repository.

My setup is a quite clean Windows 7 XP mode virtual machine.

regards
David      a.k.a. Alagazam

Mime
View raw message