subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiren Pillay <kirenpill...@gmail.com>
Subject Re: Can't synchronize branch with trunk
Date Fri, 01 Mar 2013 20:02:17 GMT
Hi Bob,

Its a standard merge command, that's why I haven't included it. Its a
standard merge though, it should work as far as I know.
Was wondering in what cases this issue would occur.

I will try and get the logs for you.

Regards
Kiren




On Fri, Mar 1, 2013 at 8:33 PM, Bob Archer <Bob.Archer@amsi.com> wrote:

> > Hi
> > I've encountered a strange problem, hopefully someone can help me here.
> > Below is a diagram of our repo
> > ----->trunk------mod ABC-------------------------+
> >          +                                                 |
> >          |                                                  |
> >        branch-copy WPB-------Mods XYZ---+ 1. From trunk we created a
> copy to a
> > new dev branch for workpackage-B.
> > 2. Commits XYZ where made to branch WPB
> > 3. In parallel, mods ABC where made to trunk 4. When trying to bring
> changes
> > into WPB via merge, none of the changes are seen. They are basically
> ignored.
> >
> > I've tried cherry picking as well, but this synchronization merge isn't
> working.
> > What could be wrong here?
> > This is the output from my eclipse IDE, the same happens from the
> > commandline:
> > Operation  Resource Path
> > ---------
> -------------------------------------------------------------------
> > Modified    /home/kiren/Documents/workspace-QA/V2.1.0-work-package-B
> > merge completed    /home/kiren/Documents/workspace-QA/V2.1.0-work-
> > package-B
>
> It's really difficult to tell here from the limited information. I assume
> Eclipse uses the svn libs rather than show you the command line.
>
> Can you run the command from the command line using svn.exe, show us your
> command and the output?
>
>
>

Mime
View raw message