subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Варфоломеев Игорь <...@mail.ru>
Subject RE: svn move and <at> sign in filepath
Date Thu, 11 Jul 2013 16:17:21 GMT
> From: 'Daniel Shahaf' [mailto:d.s@daniel.shahaf.name]
> Sent: Wednesday, July 10, 2013 9:53 PM
> 
> I am sure similar points were made on dev@ when the 'svn add
> foo@' problem was discussed there last year (that's part of the reason I
> asked you to search for already-filed issues before filing an issue about add:
> it's possible we decided to followthe semantics you describe, so even 'svn
> add' targets require peg escaping for consistency).

I think I've just found the discussion you're talking about:
http://thread.gmane.org/gmane.comp.version-control.subversion.devel/129600

Indeed, two similar issues are mentioned there: 
http://subversion.tigris.org/issues/show_bug.cgi?id=3416
http://subversion.tigris.org/issues/show_bug.cgi?id=3651
but they are both marked as "RESOLVED"...  
Issue #3651 looks very similar...

Thanks for the hint!
I've also just added an according notice to Issue #4392
( http://subversion.tigris.org/issues/show_bug.cgi?id=4392 )


As for test script - I think it might be quite similar to 
http://svn.apache.org/viewvc/subversion/trunk/subversion/tests/cmdline/copy_tests.py?annotate=952992&pathrev=952992

test, designed for issue #3651
(it's referenced in http://thread.gmane.org/gmane.comp.version-control.subversion.devel/129600
).

> Would you be interested in writing patches and/or regression tests for these
> issues?  

I'd love to, but I've got a couple of deadlines ahead in a couple of weeks...
Maybe... If no one else would fix this before...


Mime
View raw message