subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Levy <>
Subject File URLs truncated on Windows with mapped and SUBST drives
Date Wed, 28 Aug 2013 00:43:46 GMT
This was originally reported on the TSVN Users list but I've
reproduced it with the command line client. Original thread:

Jason Dunaway is using a mapped network drive for his repository, but
I reproduced the behavior with a drive letter created with SUBST.

We're both using SVN 1.8.1. He's on XP (pretty sure), I'm on Windows 7
Pro 64-bit.

Steps to reproduce:

>svnadmin create r:\Appraisal
>subst X:\ R:\Appraisal
>svn co file:///X:/ r:/tmp6

Everything to this point is successful.

>svn mkdir file:///X:/Appraisal -m "test"
Committed revision 1.

>md r:\tmp7

    Directory: R:\

Mode                LastWriteTime     Length Name
----                -------------     ------ ----
d----        08/27/2013     10:22            tmp7

>svn co file:///X:/Appraisal r:\tmp7
>svn: E160005: Target path '/ppraisal' does not exist

Note that the A in Appraisal has been chopped off. Thinking that it
might be just that one letter, I tried a different one.

>svn mkdir file:///X:/TryAgain -m "test"
Committed revision 2.

>svn co file:///X:/TryAgain r:\tmp8
svn: E160005: Target path '/ryAgain' does not exist

Same result. The T has been lopped off.

If I use the real path to the repository (not the SUBST drive letter),
it's successful:

>svn co file:///R:/Appraisal/TryAgain r:\tmp9
Checked out revision 2.

Jason was successful when using the full UNC path instead of the
mapped drive letter, which is consistent with my results with the
SUBST vs. real paths.

View raw message