subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Reser <...@reser.org>
Subject Re: Error during 'svn export' over http with serf 1.3.1
Date Wed, 11 Sep 2013 01:39:21 GMT
On 9/10/13 2:31 PM, Curt Sellmer wrote:
> After giving it more time I can now reproduce the problem with both
> version 1.8.0 and 1.8.3 of the client.  And I have now seen the
> problem with both the older and newer versions of the repository.
> Very hard to debug as it does not seem to follow any pattern.   As I
> posted earlier, it was working without a hitch for several minutes of
> testing.  Then I went through a period where it failed more than
> succeeded.  A bit later it was failing more sporadically, regardless
> of which version of the client.
> I can say this with complete confidence, but it seems that the 1.8.3
> client fails more with the old repo and the 1.8.0 client fails more
> with the new repo, but I can verify that the both have failed with
> both repos.
> 
> With 1.8.0 I see the following errors (separate runs):
> svn: E160004: Corrupt node-revision '3-1.0-489.r495/2100'
> 
> svn: E120104: ra_serf: An error occurred during decompression
> 
> ------------
> With 1.8.3 I get the same errors but the reporting for the Corrupt
> node is different:
> svn: E175002: Unexpected HTTP status 400 'Bad Request' on
> '/svn/www/!svn/rvr/496/branches/rails-3.2'
> 
> svn: E160004: Additional errors:
> svn: E160004: Corrupt node-revision '3-1.0-489.r495/2100'
> 
> And again both errors can be seen against both repos.
> I ran svnadmin verify again against both repos with no errors reported.

Can you please post the output of:
svn --version --verbose

If that command doesn't show that you're using serf 1.3.1 can you please
rebuild using the 1.3.1 version of the serf library?

The minimum required serf version is still 1.2.1 in 1.8.0-1.8.3.  Serf 1.3.0
and 1.3.1 have fixed quite a few bugs that impact Subversion users, but they
also switched to using the SCons build system that may present some trouble for
people building.  Since most of the issues fixed in serf are relatively rare we
haven't raised the minimum required version.

If after you've upgraded serf to 1.3.1 and if you are still having the issue it
could still either be a bug in Subversion or a bug in Serf.

Mime
View raw message