subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Reser <...@reser.org>
Subject Re: Error during 'svn export' over http with serf 1.3.1
Date Wed, 11 Sep 2013 07:32:52 GMT
On 9/10/13 10:41 PM, Curt Sellmer wrote:
> I now have svn 1.8.3 with serf 1.3.1.   I am not seeing the "svn:
> E120104: ra_serf: An error occurred during decompression" error as
> often at the moment.  Have seen it a few times.
> 
> But I do intermittently get several different errors as show below.
>    -  Note that I am running the command over and over repeatedly many times.
>    -  I again performed 'svnadmin verify' with no errors reported.
>    - I also ran these commands on the server box using the file://
> scheme and never once saw an error.
> 
> --------------------------
> $ svn cat http://gemini2/svn/ezappliance/trunk/README
> svn: E175002: Unable to connect to a repository at URL
> 'http://gemini2/svn/ezappliance/trunk'
> svn: E175002: Unexpected HTTP status 500 'Internal Server Error' on
> '/svn/ezappliance/trunk'
> 
> svn: E160004: Additional errors:
> svn: E160004: Corrupt representation '13 1653716 109 109
> a6a53d8aefe9d34461e08f7521119e5f'
> 
> --------------------------
> $ svn cat http://gemini2/svn/ezappliance/trunk/README
> svn: E175002: Unable to connect to a repository at URL
> 'http://gemini2/svn/ezappliance/trunk'
> svn: E175002: Unexpected HTTP status 500 'Internal Server Error' on
> '/svn/ezappliance/trunk'
> 
> svn: E160004: Additional errors:
> svn: E160004: Corrupt node-revision '0-1.0.r13/1653516'
> 
> --------------------------
> $ svn log http://gemini2/svn/bedrock/trunk/Rakefile@3
> svn: E175002: Unable to connect to a repository at URL
> 'http://gemini2/svn/bedrock/trunk/Rakefile'
> svn: E175002: Unexpected HTTP status 500 'Internal Server Error' on
> '/svn/bedrock/trunk/Rakefile'
> 
> svn: E160004: Additional errors:
> svn: E160004: Corrupt representation '29 13323 277 277
> 634ce706c8679810cb16ec44c9c6c532'

Are you sure the server end is ok?  Those errors are signs of a corrupted
repository.  I'm starting to wonder if you're not having issues due to a
hardware issue on the server side.  Failing memory could explain the behavior
you're seeing.


Mime
View raw message