subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 赖树良 <lsl6...@163.com>
Subject Re:Re: the question of create a version of the library that contains chinese
Date Mon, 16 Sep 2013 15:47:50 GMT
Thanks very much for your early reply.

The infomations of The Apahce error log(/var/log/httpd/error_log) is as follows,
[Mon Sep 16 08:21:26 2013] [error] [client 192.168.232.1] (20014)Internal error: Can't convert
string from 'UTF-8' to native encoding:
[Mon Sep 16 08:21:26 2013] [error] [client 192.168.232.1] Could not fetch resource information.
 [500, #0]
[Mon Sep 16 08:21:26 2013] [error] [client 192.168.232.1] Could not open the requested SVN
filesystem  [500, #22]
[Mon Sep 16 08:21:26 2013] [error] [client 192.168.232.1] Could not open the requested SVN
filesystem  [500, #22]

Detailed Configuration as follow,
/etc/httpd/conf/httpd.conf:
&lt;Location /svn/&gt;
DAV svn
SVNListParentPath on
SVNParentPath /opt/svn/repo/
AuthzSVNAccessFile /opt/svn/repo/authz.conf
AuthType Basic
AuthName "Subversion.zoneyump"
AuthUserFile /opt/svn/repo/authfile
Require valid-user
&lt;/Location&gt;

the directory"/opt/svn/repo/" contains 2 Repositories as follows:
[root@localhost repo]# cd /opt/svn/repo
[root@localhost repo]# ls -l
total 40
drwxrwxrwx 6 apache apache   4096 Sep 13 04:30 520项目
-rwxrwxrwx 1 apache apache   39 Sep 15 09:13 authfile
-rwxrwxrwx 1 apache apache  249 Sep 15 09:21 authz.conf
drwxrwxrwx 6 apache apache 4096 Sep 15 08:34 test01


the one that the name contains chinese Characters(520项目) can't work,
another one that the name does not contain Chinese characters(test01)  is correct,

I want to make sure whether it supports the creation of a repository with the Chinese characters?
在 2013-09-16 21:57:54,"Andy Levy" <andy.levy@gmail.com> 写道:
>On Mon, Sep 16, 2013 at 9:38 AM, lsl6631 <lsl6631@163.com> wrote:
>> Hi,I want to know if SVN (be installed on Redhat linux 5.3) support to
>> create a version of the library that contains chinese ?
>>
>>
>>
>> I  have installed ths svn via the order below,
>>
>> yum install httpd httpd-devel subversion mod_dav_svn.
>>
>>
>>
>> Finally I have try to visit the library address via IE, and displayed below:
>>
>> <m:human-readable errcode="2">
>> Could not open the requested SVN filesystem
>> </m:human-readable>
>>
>> And I am sure the englise version library is absolutely correct.
>>
>> I'm looking forward to your early reply. Thanks a lot.
>
>What does your Apache error log indicate?
>
>Are you certain that you've configured Apache to point to the correct
>directory for your repository (taking into account
>SVNPath/SVNParentPath)?


Mime
View raw message