subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Ewald <cy...@nuclex.org>
Subject Re: Commits failing with E160013 (File not found: transaction 'x-y')
Date Thu, 07 Nov 2013 09:21:50 GMT
On Sunday, October 13, 2013 10:40:14 AM UTC+2, I wrote:
>
> Hi!
>
> I'm serving a batch of repositories via Subversion 1.7.13 on Apache 2.2.25 
> (using HTTPS webdav; all on x64 Linux). Lately, I've been unable to commit 
> my changes to some files, getting error messages like in the subject line 
> of this email:
>
>     E:\assets\free\Nature\shareaec.com\3D Hanging Plant>svn status
>     M       HangingPlant.blend
>     
>     E:\assets\free\Nature\shareaec.com\3D Hanging Plant>svn commit -m 
> "Fixed transparency"
>     Sending        HangingPlant.blend
>     Transmitting file data .svn: E155011: Commit failed (details follow):
>     svn: E155011: File 'E:\assets\upgraded\Nature\shareaec.com\3D Hanging 
> Plant\HangingPlant.blend' is out of date
>     svn: E160013: File not found: transaction '39-1a', path '/Nature/
> shareaec.com/3D%20Hanging%20Plant/HangingPlant.blend'
>
> If I remove the file in question from history (via svndumpfilter) and 
> commit it as new, the commit succeeds. But when I commit changes to it, 
> E160013 occurs.
>
> I've tried from a clean checkout, after 'svn up', after rebooting the 
> server, after 'svnadmin dump', 'svnadmin create', 'svnadmin load' and 
> checked the repository with 'svnadmin lstxns'. This happens with all 
> clients I tried (TortoiseSvn 1.7.0, TortoiseSvn 1.7.3, TortoiseSvn 1.8.2, 
> command line 1.7.3 on Windows, command line 1.8.3 on Windows, command line 
> 1.7.13 on Linux compiled from same sources as the server). Access rights to 
> the repositories are given. The problem isn't limited to a single 
> repository either.
>
> The only bug I could find that possibly relates to this is 
> https://issues.apache.org/bugzilla/show_bug.cgi?id=55304 but it's 
> supposedly solved since Subversion 1.7.11.
>
> Does anyone have an idea what's going on or how I could find the cause of 
> my troubles? Any more info I should provide?
>


Still stuck on this issue.

I'm now running Subversion 1.8.4 on the server and trying to commit with 
TortoiseSVN 1.8.2 (built against Subversion 1.8.3).

With SVNAdvertiseV2Protocol off, I get aforementioned error message.
With SVNAdvertiseV2Protocol on, I get 500 internal server error (only on 
commits, browsing works)

It may be related to paths with spaces in them, as all problem cases so far 
have involved spaces.


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message