subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Reser <>
Subject Re: Empty rpath when attempting make swig-py
Date Wed, 20 Nov 2013 03:31:53 GMT
On 11/16/13 8:53 PM, jason mazzotta wrote:
> Hi,
>     I am trying to build the swig python bindings for subversion on Mac OS X.
>  I downloaded source for subversion from here:

I don't see Subversion listed on that site.  However my guess would be that's a
really old version since Apple as far as I know is still shipping 1.7.x (or
1.6.x if you're on an older version of OS X).

So I'd suggest you get a copy of the source from the project site here:

Alternatively you could just get a binary package.  I know for instance that
the WANdisco binaries include bindings:

If you still want to build anyway.  Note that in order for SWIG bindings to
build properly on OS X you'll need to regenerate the swig interface source
files.  We include pre-built ones but there's an issue where the pre-built ones
don't work on OS X.  In order to do this you need to have SWIG installed,
autoconf and libtool.  Once you've done that starting with a fresh extracted
tarball run:


>From there you should be able to build with the normal build process like you
did here:

> I ran configure as follows:
> ./configure --prefix=/usr --with-swig --enable-swig-bindings=python
> Make works.  But then, when I run:
> make swig-py
> I get the following error from libtool 
> cd subversion/bindings/swig/python/libsvn_swig_py && /bin/sh
> /Users/fred/sandbox/subversion-52/subversion/libtool --tag=CC --silent
> --mode=link gcc  -g -O2     -rpath  -bundle -undefined dynamic_lookup -Wl,-F.
> -o <>  swigutil_py.lo
> ../../../../../subversion/libsvn_client/
> <> ../../../../../subversion/libsvn_wc/
> <> ../../../../../subversion/libsvn_ra/
> <>
> ../../../../../subversion/libsvn_delta/
> <>
> ../../../../../subversion/libsvn_subr/
> <> -L/usr/lib -R/usr/lib -laprutil-1 -lldap -llber
> -llber    -lexpat -liconv    -lsqlite3        -lldap -llber -llber -L/usr/lib
> -R/usr/lib -lapr-1 -lpthread -framework Security -framework CoreFoundation
> -framework CoreServices
> libtool: link: only absolute run-paths are allowed
> make: *** [subversion/bindings/swig/python/libsvn_swig_py/
> <>] Error 1

This error doesn't look familar to me.  But I can say that I don't have an
empty -rpath with our 1.8.4 source.

> I think this is because -rpath doesn't have anything after it.  I looked at the
> swig-py target in the Makefile and found the following:
> swig-py: autogen-swig-py copy-swig-py
> I can't find the target autogen-swig-py in the Makefile.  Can anyone tell me
> where I can find this target defined?  Is there somewhere else I should look to
> find why -rpath is empty above?

In the source directory in the file named (which is included
part way through the Makefile).  However, I'd suggest you not go down the dark
path of debugging the build without first trying a newer source package.

If nothing else you almost always want the newest version of the bindings since
we fix bugs in them on a regular basis.

View raw message