subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Listman <list....@bluejeantime.com>
Subject Re: Problem with installing subversion 1.8.5 with apache 2.4.3
Date Fri, 03 Jan 2014 20:41:29 GMT
Thanks for the idea of checking for incompatibility.  


ZK


On Jan 3, 2014, at 3:31 PM, Branko Čibej <brane@wandisco.com> wrote:

> On 03.01.2014 21:15, Listman wrote:
>> I am installing apache 2.4.3 and subversion 1.8.5 and I keep getting this error when
starting apache:
>> 
>> Unknown DAV provider: svn
>> 
>> I researched the internet and reread the INSTALL instructions in subversion and I
can’t get it to work.  
>> 
>> Here is my apache config:
>> 
>> <Location /svn>
>>    DAV svn <— this line causes the error
>> #This directive allows serving multiple repos
>>    SVNParentPath /var/repos
>>    SVNListParentPath on
>>  SVNAutoversioning on
>>    ModMimeUsePathInfo on
>>   SVNAllowBulkUpdates On
>> #Access control policy
>>         AuthzSVNAccessFile /etc/svn-policy
>>         Authtype basic
>>         AuthName "Subversion Repository!"
>>         AuthUserFile /etc/svn-auth-file
>> #<LimitExcept CONNECT GET PROPFIND OPTIONS REPORT>
>>          Require valid-user
>> #</LimitExcept>
>> SVNIndexXSLT "/svnindex.xsl"
>> </Location>
>> 
>> I have linked all of the proper mods to apache.
> 
> Instead of just making that statement, I suggest you verify that you do in fact have
the correct LoadModule statements for mod_dav and mod_dav_svn in your configuration file.
Most likely, mod_dav_svn is not being loaded.
> 
> If the configuration is indeed correct, then check your error.log; there might be an
incompatibility between mod_dav_svn.so and your HTTPd version.
> 
> -- Brane
> 
> 
> -- 
> Branko Čibej | Director of Subversion 
> WANdisco // Non-Stop Data 
> e. brane@wandisco.com


Mime
View raw message