subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nico Kadel-Garcia <nka...@gmail.com>
Subject Re: upgrade to subversion 1.8.5 suspected bug
Date Wed, 22 Jan 2014 01:12:59 GMT
Do you have another web server running on port 80? And does the
WanDisco server tweak the standard "httpd" package's configuration, or
does it install another fully equipped "httpd"?

You should be able to run tools like "netstat" and "lsof" to see what
has the port open.

On Tue, Jan 21, 2014 at 12:04 AM, Austin Mico <un.f.m.o.j@gmail.com> wrote:
>
> Sorry, this is a private repository.
>
> The subversion is 1.8.4 (r1534716)
>
> mod_dav_svn.x86_64 1.8.4-2
>
> Here is the yum update command:
>
>  yum update subversion
> Loaded plugins: fastestmirror
> Loading mirror speeds from cached hostfile
>  * base: mirrors.arsc.edu
>  * extras: mirrors.lga7.us.voxel.net
>  * ius: archive.linux.duke.edu
>  * updates: mirror.clarkson.edu
> Setting up Update Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package subversion.x86_64 0:1.8.4-2 will be updated
> --> Processing Dependency: subversion = 1.8.4-2 for package:
> mod_dav_svn-1.8.4-2.x86_64
> ---> Package subversion.x86_64 0:1.8.5-1 will be an update
> --> Running transaction check
> ---> Package mod_dav_svn.x86_64 0:1.8.4-2 will be updated
> ---> Package mod_dav_svn.x86_64 0:1.8.5-1 will be an update
> --> Finished Dependency Resolution
>
> Dependencies Resolved
>
> =============================================================================================================================================================
>  Package                                 Arch
> Version                               Repository
> Size
> =============================================================================================================================================================
> Updating:
>  subversion                              x86_64
> 1.8.5-1                               WANdisco
> 2.2 M
> Updating for dependencies:
>  mod_dav_svn                             x86_64
> 1.8.5-1                               WANdisco
> 76 k
>
> Transaction Summary
> =============================================================================================================================================================
> Upgrade       2 Package(s)
>
> Total download size: 2.2 M
> Is this ok [y/N]:
> Downloading Packages:
> (1/2): mod_dav_svn-1.8.5-1.x86_64.rpm
> |  76 kB     00:00
> (2/2): subversion-1.8.5-1.x86_64.rpm
> | 2.2 MB     00:02
> -------------------------------------------------------------------------------------------------------------------------------------------------------------
> Total
> 616 kB/s | 2.2 MB     00:03
> Running rpm_check_debug
> Running Transaction Test
> Transaction Test Succeeded
> Running Transaction
>   Updating   : subversion-1.8.5-1.x86_64
> 1/4
>   Updating   : mod_dav_svn-1.8.5-1.x86_64
> 2/4
> Stopping httpd: [  OK  ]
> Starting httpd: [  OK  ]
>   Cleanup    : mod_dav_svn-1.8.4-2.x86_64
> 3/4
>   Cleanup    : subversion-1.8.4-2.x86_64
> 4/4
> Stopping httpd: [FAILED]
> Starting httpd: (98)Address already in use: make_sock: could not bind to
> address 0.0.0.0:80
> no listening sockets available, shutting down
> Unable to open logs
> [FAILED]
>   Verifying  : mod_dav_svn-1.8.5-1.x86_64
> 1/4
>   Verifying  : subversion-1.8.5-1.x86_64
> 2/4
>   Verifying  : subversion-1.8.4-2.x86_64
> 3/4
>   Verifying  : mod_dav_svn-1.8.4-2.x86_64
> 4/4
>
> Updated:
>   subversion.x86_64 0:1.8.5-1
>
> Dependency Updated:
>   mod_dav_svn.x86_64 0:1.8.5-1
>
> Complete!
>
>
> On vhost config
>
> This line exist:
>
> LoadModule dav_svn_module     modules/mod_dav_svn.so
> LoadModule authz_svn_module modules/mod_authz_svn.so
>
> <Location /repos>
>  DAV svn
>  SVNParentPath /var/svn-repos
>  SVNPathAuthz off
>  #...Authentication configuration here
> </Location>
>
> If you have this code below which can be viewed exactly like this on browser
> on version 1.8.4
>
> <?php
>
> // Define path to application directory
> defined('APPLICATION_PATH')
>     || define('APPLICATION_PATH', realpath(dirname(__FILE__) .
> '/../application'));
>
> // Define application environment
> defined('APPLICATION_ENV')
>     || define('APPLICATION_ENV', (getenv('APPLICATION_ENV') ?
> getenv('APPLICATION_ENV') : 'production'));
>
> // Ensure library/ is on include_path
> set_include_path(implode(PATH_SEPARATOR, array(
>     realpath(APPLICATION_PATH . '/../library'),
>     get_include_path(),
> )));
>
> /** Zend_Application */
> require_once 'Zend/Application.php';
>
> // Create application, bootstrap, and run
> $application = new Zend_Application(
>     APPLICATION_ENV,
>     APPLICATION_PATH . '/configs/application.ini'
> );
> $application->bootstrap()
>             ->run();
>
>
> Here is the the source code viewed on browser after installing 1.8.5-1.
>
> bootstrap() ->run();
>
> I hope these details should help.
>
> Regards,
>
> Austin

Mime
View raw message