subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Crim <john.c...@adap.tv>
Subject assert+fail when copying a directory
Date Fri, 29 Aug 2014 13:31:29 GMT
I first tried copying a directory in TortoiseSvn within the same parent
directory, and received the assert error + failure.  Then I tried the same
operation from the command line and got the same exception:

Running Windows 8.1, svn 1.8.8

This operation completely describes what I was doing - after the first
error, I ran svn cleanup, svn revert -R . - so I'm starting from a clean
state.

C:\src\code\Tools\Templates\WebApp\test>svn st

C:\src\code\Tools\Templates\WebApp\test>dir
 Volume in drive C has no label.
 Volume Serial Number is 6C5D-2637

 Directory of C:\src\code\Tools\Templates\WebApp\test

08/29/2014  06:26 AM    <DIR>          .
08/29/2014  06:26 AM    <DIR>          ..
08/29/2014  06:27 AM    <DIR>          DataAccess.IntegrationTests
08/27/2014  10:13 PM    <DIR>          Model.UnitTests
08/29/2014  06:27 AM    <DIR>          Web.IntegrationTests
               0 File(s)              0 bytes
               5 Dir(s)  80,145,203,200 bytes free

C:\src\code\Tools\Templates\WebApp\test>svn cp Web.IntegrationTests
Web.UnitTests
A         Web.UnitTests
svn: E235000: In file
'D:\Development\SVN\Releases\TortoiseSVN-1.8.6\ext\subversion\subversion\libsvn_wc\wc_db.c'
line 4347: assertion faile
d (kind == svn_node_file || kind == svn_node_dir)


I hope this is helpful, I was pretty surprised to see this use case fail to
work.

--John

Mime
View raw message