subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Corveleyn <jcor...@gmail.com>
Subject Re: stuck at out of date error when rename/delete files
Date Sat, 22 Nov 2014 19:18:35 GMT
Strange. Have you tried 'svn revert deletedfile'. Maybe that will get you
out of this situation.

Johan
Op 22-nov.-2014 15:24 schreef "James" <oldyoungguy88@yahoo.com>:

> The KDE SVN tells me these two files are NOT under version control but
> they are listed as "deleted". Usually the deleted files will not be listed
> on its window.
>
>   ------------------------------
>  *From:* James <oldyoungguy88@yahoo.com>
> *To:* "users@subversion.apache.org" <users@subversion.apache.org>
> *Sent:* Saturday, November 22, 2014 9:18 AM
> *Subject:* stuck at out of date error when rename/delete files
>
> I am using latest SVN in linux with KDE SVN and eclipse. I have problem to
> commit the delete action. I was renamed two files along with other changes.
> After several different ways to commit my changes with KDE SVN, Eclipse and
> command line. Now these two files were renamed. The new files were in but
> the old named files were marked as "delete". I cannot commit them.
>
> The files are not physically exist on the machine. "svn status" will list
> them as "D". And they are displayed in the KDE SVN as "delete" as well. I
> am trying to commit the deletion. The result tell me the files are "out of
> date" and "path not found". I tried "svn update" , "svn resolved fileName"
> and "svn commit -m "comments"  fileNames". The results are the same.
>
> I was able to rename files before. But I don't know why it doesn't work
> for me this time. Is there a way to commit this deletion?
>
> Thanks,
>
> James
>
>
>

Mime
View raw message