subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pascal.sandrez@freescale.com" <pascal.sand...@freescale.com>
Subject RE: SVN commit does nothing
Date Thu, 12 Mar 2015 16:59:30 GMT
I also think that "something" is interfering with this request but I don't know how to identify
this issues as I don't master these technologies and don't see any error.
But thanks, I take note that it would be better to install version 1.8 anyway.
Pascal

-----Original Message-----
From: Philip Martin [mailto:philip.martin@wandisco.com] 
Sent: Thursday, March 12, 2015 4:40 PM
To: Sandrez Pascal-B09824
Cc: Johan Corveleyn; Eric Johnson; Les Mikesell; users@subversion.apache.org
Subject: Re: SVN commit does nothing

Subversion 1.8 works with httpd 2.2.  Something (a module, a proxy, a load balancer) is interfering
with POST requests.  The best solution is to identify what is interfering with POST and fix
it, but if you cannot do that you are advised to run 1.8 with "SVNAdvertiseV2Protocol off"
rather than 1.6. 1.6 has lower performance, more bugs, and is no longer supported.

"pascal.sandrez@freescale.com" <pascal.sandrez@freescale.com> writes:

> Hi
>
> I tried to set “SVNAdvertiseV2Protocol off” and it worked!
> It’s something like subversion > 1.6 and httpd 2.2 can’t work properly together.
> Finally I compiled subversion 1.6 which is enough for the purpose of 
> this installation and that is OK
>
> Thanks a lot for your help!
>
> Pascal
>
>
> From: Johan Corveleyn [mailto:jcorvel@gmail.com]
> Sent: Wednesday, March 11, 2015 7:37 PM
> To: Sandrez Pascal-B09824
> Cc: Eric Johnson; Les Mikesell; users@subversion.apache.org
> Subject: RE: SVN commit does nothing
>
>
> Op 11-mrt.-2015 18:32 schreef
> "pascal.sandrez@freescale.com<mailto:pascal.sandrez@freescale.com>"
> <pascal.sandrez@freescale.com<mailto:pascal.sandrez@freescale.com>>:
>>
>> I'm in a company that use redhat as base distribution. I asked for a 
>> web server to migrate some tools from an old server. I asked for 
>> recent versions of some tools like php, perl or mysql.
>> For this reason (mostly compile a newer version of php) and to be 
>> able to put all the binaries and configuration on a storage with 
>> backup they gave me a custom web stack compiled with httpd 2.2. Now I 
>> have to add svn, that's why I compiled it from source.
>> I found that discussion where POST request where not handled by svn. 
>> Except I have to error, it seems I face the same kind of
>> problem:
>> http://grokbase.com/t/subversion/users/123tdmwx9x/subversion-1-7-server-client-issue-not-able-to-commit-e160013-path-not-found.
>
> That doesn't sound like the same issue to me. That thread mentions a 
> specific error message (E160013 path not found) while you said commit 
> just does nothing (hangs until timeout or something). Or did you 
> forget to add the tiny detail that you got an error ;-) ?
>
> Apart from that, the thread does suggest something to try: did you 
> test if the issue goes away if you set "SVNAdvertiseV2Protocol off"?
>
> --
> Johan

--
Philip Martin | Subversion Committer
WANdisco // *Non-Stop Data*
Mime
View raw message