subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pascal.sandrez@freescale.com" <pascal.sand...@freescale.com>
Subject RE: SVN commit does nothing
Date Tue, 10 Mar 2015 16:26:45 GMT
Hi Eric
Thanks for your answer.

The repository are well created under the location ___/svn and I can access them through http,
that’s fine.
Error log from apache does not show anything.
I added svn logging in httpd.conf (following this http://svnbook.red-bean.com/en/1.7/svn.serverconfig.httpd.html#svn.serverconfig.httpd.extra.logging),
I see read operations being done (update, or show log from tortoise) but not the commit.
I tried to checkout and commit directly on the machine (as the same user running apache) using
file:///<file:///\\> and commit works!
That’s a first step but I don’t see what is wrong then…

Thanks
Pascal

From: Eric Johnson [mailto:eric@tibco.com]
Sent: Tuesday, March 10, 2015 4:32 PM
To: Sandrez Pascal-B09824
Cc: users@subversion.apache.org
Subject: Re: SVN commit does nothing

After you have created repositories, do you see them listed when you browse to the ____/svn
location in your browser. Do the error logs for Apache show anything? Have you checked into
all the logging options for Subversion + Apache (sorry, don't have the link handy from my
phone)?

Also, try checkout and commit directly on the machine (as the same user running Apache), using
file:///<file:///\\> URLs, and see if that reports anything that gives you a clue as
to whether it is working. Or does it just work?

Eric

On Mar 10, 2015, at 7:53 AM, "pascal.sandrez@freescale.com<mailto:pascal.sandrez@freescale.com>"
<pascal.sandrez@freescale.com<mailto:pascal.sandrez@freescale.com>> wrote:
Hi

I recently installed svn module (1.8.11) for apache (2.2.24). I compiled successfully everything
without issue but I can’t have it working properly, I need help of advanced users.
I can create repository with svnadmin or copy repository from existing installation. I didn’t
set any rights limitation for now to be able to easily test installation.
Repository checkout or update is working fine using tortoise or command line client. Repository
read through web browser is also working fine.

BUT commit does nothing. When I try to commit existing or new file, from tortoise or command
line, commit starts and is never done. It seems to be doing the commit until timeout occur
(few minutes) or I cancel it. I don’t have any error message, nothing to debug. In httpd
access log I see an OPTION request, that’s all. Nothing in error log.

My configuration is like this:

LoadModule dav_module lib/httpd/modules/mod_dav.so
LoadModule dav_fs_module lib/httpd/modules/mod_dav_fs.so
LoadModule dav_svn_module     libexec/mod_dav_svn.so
LoadModule authz_svn_module   libexec/mod_authz_svn.so

DavLockDB "/opt/amon/var/DavLock"

<Location /svn>
    DAV svn
    SVNParentPath /opt/amon/var/www/svn
    SVNListParentPath On
</Location>

Apache user and group is the same as user creating the repository.

After few days searching I don’t see anything else to do, what could I check now?

Thanks for your help!

Regards
Pascal

Mime
View raw message