subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Aron Bloom <sc...@towel42.com>
Subject RE: Issue in svn E195020
Date Mon, 06 Apr 2015 23:23:08 GMT
>
> =========================
> I did notice that... (the version being the same for Prerequisites)
>
> Here is the line from the externals definition
>
> -r 28594 ^/externals/microsoft/Prerequisites Prerequisites
>
> It is a directory, that contains the VS 2013 and VS 2008 pre-req distribution executable
installers for our install creation phase.

Sorry it took a while ... I tried to reproduce your issue from scratch, but I can't get it
into the blocking mixed-rev situation (the svnversion of the form NNN:MMMS). There must be
something else playing a role.

This is what I tried:

[[[
C:\mixed_rev>svn --version -q
1.8.11-SlikSvn-1.8.11-X64

### make new repository and build up the basics C:\mixed_rev>svnadmin create repos

C:\mixed_rev>svn co file:///c:/mixed_rev/repos wc Checked out revision 0.

C:\mixed_rev>cd wc

C:\mixed_rev\wc>svn mkdir trunk branches tags externals
A         trunk
A         branches
A         tags
A         externals

C:\mixed_rev\wc>svn ci -mm
Adding         branches
Adding         externals
Adding         tags
Adding         trunk

Committed revision 1.

C:\mixed_rev\wc>svn up
Updating '.':
At revision 1.

C:\mixed_rev\wc>svnversion
1

### create dir under /externals
C:\mixed_rev\wc>svn mkdir externals\dir
A         externals\dir

C:\mixed_rev\wc>svn ci -mm
Adding         externals\dir

Committed revision 2.

C:\mixed_rev\wc>cd trunk

### define svn:externals on /trunk, referring to fixed revision of /externals/dir C:\mixed_rev\wc\trunk>svn
pe svn:externals .
Set new value for property 'svn:externals' on '.'
### value set to "-r 2 ^/externals/dir dir"

C:\mixed_rev\wc\trunk>svn ci -mm
Sending        .

Committed revision 3.

### create a branch, just for fun
C:\mixed_rev\wc\trunk>svn cp -mm file:///c:/mixed_rev/repos/trunk
file:///c:/mixed_rev/repos/branches/br1

Committed revision 4.

C:\mixed_rev\wc\trunk>svnversion
3

C:\mixed_rev\wc\trunk>cd ..

C:\mixed_rev\wc>svn up
Updating '.':
A    branches\br1

Fetching external item into 'branches\br1\dir':
Updated external to revision 2.


Fetching external item into 'trunk\dir':
External at revision 2.

At revision 4.

### svnversion still clean -- here I would have perhaps expected 2:4S C:\mixed_rev\wc>svnversion
4

C:\mixed_rev\wc>cd ..

### Let's see if it works with a wc of only trunk (where ^/externals is outside) C:\mixed_rev>svn
co file:///c:/mixed_rev/repos/trunk wc_trunk
 U   wc_trunk

Fetching external item into 'wc_trunk\dir':
Checked out external at revision 2.

Checked out revision 4.

C:\mixed_rev>cd wc_trunk

### nope, svnversion still clean.
C:\mixed_rev\wc_trunk>svnversion
4
]]]

Can you try to come up with a reproducible example? Or perhaps point out other special things
that I might try on my test repository / working copy?

--
Johan
================
What I found that was "different" is the external repo that had the same version of the screwy
svnversion number, had spaces in the name of the svn path.. as well as the name of the path
it checked out to.

When I renamed them, and moved forward, it seems to have fixed things..

Scott
Mime
View raw message