subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Martin <philip.mar...@wandisco.com>
Subject Re: Compilation issues
Date Fri, 19 Jun 2015 17:16:50 GMT
Werner Freund <wsfreund@gmail.com> writes:

> I keep getting this error:
>
>> libtool: link: warning: library
>> `/home/wsfreund/custom_installed/lib/libapr-1.la' was moved. /bin/sed:
>> can't read /usr/local/apr/lib/libapr-1.la: No such file or directory
>> libtool: link: `/usr/local/apr/lib/libapr-1.la' is not a valid libtool
>> archive make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1
>
> during the linkage:
>
>     cd subversion/libsvn_subr && /bin/bash
> "/home/wsfreund/custom_installed/svn/libtool" --tag=CC --silent
> --mode=link gcc  -g -O2  -g -O2 -pthread    -rpath
> /home/wsfreund/custom_installed/lib -version-info 0 -Wl,--no-undefined
> -o libsvn_subr-1.la  adler32.lo atomic.lo auth.lo base64.lo
> bit_array.lo cache-inprocess.lo cache-membuffer.lo cache-memcache.lo
> cache.lo cache_config.lo checksum.lo cmdline.lo compat.lo compress.lo
> config.lo config_auth.lo config_file.lo config_win.lo crypto.lo
> ctype.lo date.lo debug.lo deprecated.lo dirent_uri.lo dso.lo eol.lo
> error.lo fnv1a.lo gpg_agent.lo hash.lo io.lo iter.lo lock.lo log.lo
> macos_keychain.lo magic.lo md5.lo mergeinfo.lo mutex.lo nls.lo
> object_pool.lo opt.lo packed_data.lo path.lo pool.lo prefix_string.lo
> prompt.lo properties.lo quoprint.lo root_pools.lo simple_providers.lo
> skel.lo sorts.lo spillbuf.lo sqlite.lo sqlite3wrapper.lo
> ssl_client_cert_providers.lo ssl_client_cert_pw_providers.lo
> ssl_server_trust_providers.lo stream.lo string.lo subst.lo sysinfo.lo
> target.lo temp_serializer.lo time.lo token.lo types.lo user.lo
> username_providers.lo utf.lo utf8proc.lo utf_validate.lo utf_width.lo
> validate.lo version.lo win32_crashrpt.lo win32_crypto.lo
> win32_xlate.lo x509info.lo x509parse.lo xml.lo
> -L/home/wsfreund/custom_installed/lib -laprutil-1
> -L/home/wsfreund/custom_installed/lib -lapr-1 -lexpat -lz  -ldl
> -lpthread
>
>
> What is most strange, I don't have a clue **why** it wants to find it
> on `/usr/local/apr/lib/libapr-1.la`, since it should find it on
> `/home/wsfreund/custom_installed/lib`…

What do the files libapr-1.la and libaprutil-1.la contain?

-- 
Philip Martin | Subversion Committer
WANdisco // *Non-Stop Data*

Mime
View raw message