subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan <luke1...@posteo.de>
Subject Re: Subersion 1.9 with httpd 2.4.19 compilation error
Date Mon, 10 Aug 2015 15:08:44 GMT
Hi Attilla,
> hi,
>
> i trying to complie subversion 1.9 with mod_dav_svn support on os x 10.10 and i get the
following error message:
> subversion/mod_authz_svn/mod_authz_svn.c:100:8: error: This version of httpd has a security
hole with mod_authz_svn
>
> configure parameters for subversion:
> ./configure --prefix=/path/to/my/folder/subversion \
> --with-apxs=/path/to/my/folder/apache/bin/apxs \
> --with-apr=/path/to/my/folder/apr \
> --with-apr-util=/path/to/my/folder/apr-util \
> --with-serf=/path/to/my/folder/serf
>
> apr-1.5.2
> apr-util-1.5.4
> serf-1.3.8
>
>
> httpd 2.4.16 (tried httpd-2.4.12 too)
> compiled from source with builtin apr -> same error message from subversion
> ./configure \
> --with-mpm=prefork \
> --prefix=/path/to/my/folder/apache \
> --with-pcre=/path/to/my/folder/pcre \
> --with-included-apr \
> --enable-ssl \
> --enable-http \
> --enable-so \
> --enable-unique-id \
> --enable-rewrite \
> --enable-deflate \
> --enable-dav \
> --enable-ldap \
> --with-ldap \
> --enable-authnz-ldap
>
>
> compiled from source with external apr/apr-util -> same error message from subversion
> ./configure \
> --with-mpm=prefork \
> --prefix=/path/to/my/folder/apache \
> --with-pcre=/path/to/my/folder/pcre \
> --with-apr=/path/to/my/folder/apr/bin/apr-1-config \
> --with-apr-util=/path/to/my/folder/apr-util/bin/apu-1-config \
> --enable-ssl \
> --enable-http \
> --enable-so \
> --enable-unique-id \
> --enable-rewrite \
> --enable-deflate \
> --enable-dav \
> --enable-ldap \
> --with-ldap \
> --enable-authnz-ldap
>
>
> which httpd version sould i use?
>
> thanks.
>
> Attila Soki
>
looking at the corresponding code in mod_authz_svn.c suggests that u are 
building with a httpd version < 2.4.14. As far as I'm aware there is no 
2.4.19 version yet from httpd (latest one I'c on the webpage is 2.4.16). 
So if you would build SVN with that version the error u are seeing 
should not trigger.

Is it possible that you are in fact building with a different version 
than the one u expect?
What is the value of MODULE_MAGIC_NUMBER_MAJOR/_MINOR in ur case?

Regards,
Stefan


Mime
View raw message