subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lev Serebryakov <...@FreeBSD.org>
Subject Re: subversion 1.9.2 could not be built "all-static" on FreeBSD 10+
Date Sun, 18 Oct 2015 12:02:58 GMT
Hello Daniel,

Sunday, October 18, 2015, 11:08:45 AM, you wrote:

>>  I could not build subversion 1.9.2 with "--enable-all-static" on FreeBSD.
>> "configure" script forms wron arguments to ${CC} in this case and fails to
>> find any library.
>> 
>>  Here is couple of lines from config.log for 1.9.2:
>> 
>> configure:6130: checking for sqlite3_close in -lsqlite3
>> configure:6155: cc -o conftest -Werror=unknown-warning-option -O2 -pipe  -fpic -DPIC
-fstack-protector -fno-strict-aliasing      -I/usr/local/include  -fstack-protector  -L/usr/local/lib
-L/usr/local/lib  -L/usr/local/lib -R/usr/local/lib       -L/usr/local/lib -R/usr/local/lib
          -L/usr/local/lib conftest.c -lsqlite3   >&5
>> cc: error: unknown argument: '-R/usr/local/lib'
>> cc: error: unknown argument: '-R/usr/local/lib'
>> configure:6155: $? = 1

> I assume you're building the 1.9.2 tarball, correct?  Does the problem
  Yep.

> also occur if you build from a checkout of the 1.9.2 tag?  (You'll need
> to run autogen.sh before configure.)
  Yes. Here is version of tools used by autogen.sh:

buildcheck: autoconf version 2.69 (ok)
buildcheck: autoheader version 2.69 (ok)
buildcheck: libtool version 2.4.6 (ok)

 And after that same error if "--enable-all-static" is passed.

-- 
Best regards,
 Lev                            mailto:lev@FreeBSD.org


Mime
View raw message