subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: Bug report: The auto-props setting of svn:mime-type is impossible to avoid.
Date Sat, 03 Oct 2015 11:19:34 GMT
On Sat, Oct 03, 2015 at 11:13:08AM +0200, Edward d'Auvergne wrote:
> is it really not a bug when:
> 
>     enable-auto-props = yes
> 
> and:
> 
>     enable-auto-props = no
> 
> both enable auto-props?
> 
> Cheers,
> 
> Edward

I think your best way forward is what Ryan suggested: Ensure svn:mime-type
for *.xml is set to 'text/plain' by setting svn:autoprops at the root of
your repository. Then, over time, as your users upgrade to 1.8 clients
and beyond, this problem will fix itself.

Note that setting mime-type to 'text/plain' will have the same effect
as if a file which is a "text file" (as guessed by SVN based on
implementation-defined heuristics) does not have a mime-type set.

When I added the libmagic support (yes, I'm responsible) I had to ensure
the existing auto-props mechanism kept working. So mime-type detection
with libmagic happens *after* autoprops and only if autoprops don't set
a mime-type. That's where this design decision came from.

I'm sorry this implementation doesn't work out of the box for you,
and if I had known about your situation I might have made different
choices while implementing this feature years ago. Alas, it's water
under the bridge now, and you're the first person to complain about
this ever, and there are mulitple ways you can work around the problem.

So please stop calling behaviour you don't agree with a "bug".
Call it what it is, a particular behaviour, which might not fit
every single use case out there.

I hope this works out fine for you in the end, one way or another.
I'm very happy to see SVN supporting an awesome project like yours!

Mime
View raw message