subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lev Serebryakov <...@FreeBSD.org>
Subject Re: subversion 1.9.2 could not be built "all-static" on FreeBSD 10+
Date Mon, 19 Oct 2015 12:31:00 GMT
On 19.10.2015 15:03, Lev Serebryakov wrote:

>> It looks like serf gets these flags from:
>> $ apr-1-config --link-libtool
>  It is interesting, as this line is Ok for "link-libtool" but it ends up
> in ${CC} arguments. I'm not sure, that is exactly serf, apr-1-config or
> subversion bug anymore!
 the problem is, subversion build system uses libtool for build:

/bin/sh
"/usr/home/lev/FreeBSD/ports/devel/subversion/work/subversion-1.9.2/libtool"
--tag=CC --silent --mode=compile cc -std=c90
-Werror=unknown-warning-option -O2 -pipe  -fpic -DPIC -fstack-protector
-fno-strict-aliasing   -O2 -pipe  -fpic -DPIC -fstack-protector
-fno-strict-aliasing  -I./subversion/include -I./subversion
-I/usr/local/include/apr-1   -I/usr/local/include/apr-1 -I/usr/include
-I/usr/local/include     -I/usr/local/include/serf-1
-I/usr/local/include  -I/usr/local/include  -o
subversion/libsvn_delta/editor.lo -c subversion/libsvn_delta/editor.c

 but "plain" ${CC} for configure checks. So, flags, which are could be
accepted by libtool in build process, is rejected by ${CC} in
"configure" and "configure" fails.

  Now I've solved this by fixing serf.pc, but this inconsistencw in
subversion build process looks ugly — it checks system configuration
with one compiler, but really uses completely different one!

-- 
// Lev Serebryakov

Mime
View raw message