subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delleske <delle...@avmatsim.de>
Subject Subclipse on Eclipse 3.8 on Linux Mint 17.2 (Ubuntu)
Date Tue, 27 Oct 2015 16:32:43 GMT
Dear list,

Linux Mint ( see http://www.linuxmint.com ) seems to be a variant of
Ubuntu Linux. "uname -a" says

Linux [hostname] 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38
UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

and "cat /etc/issue" says

Linux Mint 17.2 Rafaela

I've successfully installed Eclipse 3.8.1 (debbuild) via the application
manager. Next, being root, I've updated eclipse with their built-in
system. Worked seemingly.

Now, according to that page:

http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA

the first thing I need to do is install JavaHL, right?

http://subclipse.tigris.org/wiki/JavaHL#head-bb1dd50f9ec2f0d8c32246430c00e237d27a04fe

# apt-get install libsvn-java

works fine. I get the resulting location

# find / -name libsvnjavahl-1.so
/usr/lib/x86_64-linux-gnu/jni/libsvnjavahl-1.so

So when I try to test Java as suggested after having downloaded the
javahltests.jar file. When issueing

# java -Djava.library.path=/usr/lib/x86_64-linux-gnu/jni -jar
javahltests.jar

or

# java
-Djava.library.path=/usr/lib/x86_64-linux-gnu/jni/libsvnjavahl-1.so -jar
javahltests.jar

I get 50 errors, so 100% failure. Looks encouraging!

Unfortunately the howto does not say where to go from there.

Looking for answers in the web was not very helpful as there seem to
exist a plethora of versions of anything..

When I've installed subclipse several years ago, it has been equally
straining - I know that I need to enter the URL subclipse.tigris.org in
one of the next steps in order to install subclipse, but I don't know
which version.

I've seen there is a table on this page:

http://subclipse.tigris.org/wiki/JavaHL

- so I guess that as I have svn commandline client 1.8.8, I will need
the tigris subclipse URL 1.10.x?


Als a svn commandline client, I have svn 1.8.8 installed. Later, I'd
like to access a svn server with version 1.6

Thanks a lot..

*sigh*

Andreas



Mime
View raw message