subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nico Kadel-Garcia <nka...@gmail.com>
Subject Re: Problems with empty svn:date revprops (github svnsync)
Date Wed, 28 Oct 2015 13:00:38 GMT
On Wed, Oct 28, 2015 at 4:16 AM, Branko ─îibej <brane@apache.org> wrote:
> On 28.10.2015 04:39, Nico Kadel-Garcia wrote:
>> On Tue, Oct 27, 2015 at 12:07 PM, Branko ─îibej <brane@apache.org> wrote:
>>> On 27.10.2015 14:33, Nico Kadel-Garcia wrote:
>>>> See above. It sounds like you need to talk to Github about making an
>>>> exception to their default settings for revision 0. A freshly
>>>> initialized git repo, with no files or property changes submitted, has
>>>> *no* valid logs, and "git log" fails with an error. A freshly
>>>> initialized svn repo, with no files or properties set, has a no logs
>>>> but has a revision "0" created at index time.
>>>>
>>>> Like I just said: impedance mismatch.
>>> There's no such thing as "impedance mismatch" when you're implementing a
>>> wire protocol. if GitHub provides an SVN/HTTP protocol endpoint but
>> I assume that you *are* aware that the phrase "impedance mismatch"
>> comes from actual circuitry with actual wires, right?
>
> Really ... I'd never have imagined that. Still, if you want to take the
> analogy to this extreme, what you do in hardware with resistors,
> capacitors and inductors, you do in software with this little thing
> called "emulation". Apparently GitHub forgot to solder in that 10pF. :)

I was making a bit of fun of the concept that an "impedance mismatch"
cannot happen in a "wire protocol". There are lots of such mismatches,
they help pay my salary and have for decades.

>From the circuitry emulation world, emulation finds it hard to model
why switching from ceramic capacitors with leads to a surface mount
design suddenly loses a chunk of high frequency signal in DC blocking
capacitors. It's because most complex surface mount designs use a
ground plane, and the flat surface mount component couples to the
ground plane.  The problem never showed up in emulation, but became
very apparent when I got my hands on the board and actually *looked*
at it. : It's amazing how much simply mounting the capacitor on its
side instead of the normal, flat layout helped.

Emulation tools, much like wire protocols, are very useful. But you
have to actually test them to find the bugs, which happens quite a
lot, and you might have to get a bit creative to address the mismatch
until and unless it can be solved upstream. In this case, I suspect
that a hand edit of the revision properties of revision 0, before
activating svnsync, will help.

Mime
View raw message