subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@apache.org>
Subject Re: Subversion 1.8.14 won't install on OSX
Date Mon, 09 Nov 2015 19:18:53 GMT
On 09.11.2015 19:31, Dave Huang wrote:
> On Nov 9, 2015, at 4:22, Alexander Henket <ahenket@xs4all.nl> wrote:
>> Right, that's it. I downloaded the zip variant. Don't know why it should matter,
but anyway. It's working now .. sort of:
> While zip works just about everywhere these days, it has its origins in the MSDOS world,
and Windows can extract zip files without any 3rd party utilities, so I think the zip variant
is intended to be more convenient for Windows users.

The .zip variant is meant exactly for building on Windows. It does not
contain the Unix build scripts, and most files have CR/LF line endings
instead of just LF. Once upon a time, the Visual Studio editor didn't
know what to do with files with LF line endings.

>> Any other hints? Thanks in advance.
> What about the WANdisco package? It's for Yosemite, but it seems like it should work
on El Capitan too.
>
> FWIW, MacPorts subversion 1.9.2 installed with no problems on my El Capitan system. What
did /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_db46/db46/main.log
have to say about the problem?

I build Subversion regularly on OSX, and I also run an automated build
box on a Mac Mini. I do use Homebrew to get a new-enough openssl, scons
(for Serf), atoconf etc. (not on the buildslave, where I build the
dependencies from scratch). The system APR, APR-Util and SQLite on El
Cap are just fine, and you do not need Berkeley DB; in fact, I'd
recommend not to build the BDB bits at all.

-- Brane

Mime
View raw message